Access to Control Tower

issues

#1

Hi,
I’m starting to explore RPAx and I was able to make a recording and publish to the Control Tower.
However when I try to access the Control Tower it asks me for credentials. Where do I setup the users to access the CT?
Thanks,
Pedro Pereira


Configure control tower to be launched using a hostname instead of default localhost
#2

hi @pedro.pereira,

These credentials are in your registration email


#3

Hi,

I’m replying because my user don’t have the previlege to open new items to the group forum and i have a question regarding the Control Tower:

  • I have installed RPA Express and all components are working but can’t start the Control Tower. Can you help me how I do this?

Thanks
Paulo


#4

@Paulo_Matias_AskBlue,

You can open Control Tower in two ways:


#5

Hi Azinchuk,

my problem is that the Control Tower does not start and I don’t know if I need to change something.

Another problem that I have is regarding my user definitions on the forum, because I don’t have the previlege to open an issue.

Best Regards
Paulo Matias


#6

@Paulo_Matias_AskBlue - we’ve updated your profile trust level - now you will be able to create new topics


#7

@Paulo_Matias_AskBlue
This might be due to RPAE_JRE_HOME
Can you just go to the installation folder /Workfusion/tomcat/bin/catalina.bat run

It will let you know if the RPAE_JRE_HOME is not found.
And if that is the case, you need to set it up in the environment variable.


#8

Hi,

when I try to run catalina bat I receive this message in the command prompt

C:\RPAExpress\Workfusion\tomcat\bin>catalina run
The RPAE_JRE_HOME environment variable is not defined correctly
This environment variable is needed to run this program

C:\RPAExpress\Workfusion\tomcat\bin>

The installation made was the default one.

Conclusion: Control Tower does not start


#9

Hi,
This means that RPAE_JRE_HOME could not be defined properly. You can do it manually.
Here are the steps you need to follow:

  1. Right click on my computer
  2. Select Properties
  3. Select ‘Advance System Settings’
  4. Click Environment Variables
  5. Under the System Variable section click New
  6. variable name: RPAE_JRE_HOME
  7. variable value: ‘C:\RPAExpress\Applications\Java\jre’ (this was the location on my machine) you need to replace it with yours.
  8. Post that just exit and reopen workfusion. It took 5-7 mins for me for the first time.

#10

What if one went and changed the password delivered in registration email - can’t revert back to original password because it doesn’t comply with the password generation rules ("Password should not contain the user name ")… Can’t publish to Control Tower because of changed password - is there some configuration file in Recorder where I can reflect the change or…?


#11

@AVirta_F,

Currently you cannot change the Control Tower credentials - please see details here - Control Tower Users


#12

Hi
Can we access control tower with other PCs with same network? @azinchuk


#13

Hi @Lasitha_Wijenayake,

If your IT Security Policy allows such actions, you can do it.

Let’s say you have the following IP: 192.168.100.55

Then your colleagues can access your Control Tower using the following URL:

http://192.168.100.55:15380/workfusion/login

Note:

  • the 15380 port should be open and your colleagues should be in the same network.
  • when multiple users will log in to your Control Tower, resource consumption can significantly grow
  • all these actions are not recommended and are done at your own responsibility

Completing manual task from RPAExpress from different PC
#14

@azinchuk
Can we execute RPA script on another PC in same network without installing Workfusion?
I’m talking about the presentation purposes.


#15

@Lasitha_Wijenayake
as you need Control Tower to execute the script, it is necessary to install RPA Express with Workfusion.


#16

Hi,
Is it possible to configure control tower to be launched using a hostname or IP Address instead of default localhost so that I can access control tower remotely. Even now its possible by providing ip address or hostname in the URL, however internal links still pointing to localhost.

Thanks
Jagathesh


#17

@JThangaswamy

You can find the solution in the post by @azinchuk in the thread, but keep in mind that such actions are not recommended.


#18

Hi,
When I try to open the workspace using url - http://hostname:15280/workspace/task , the manual task page is not loading the task details (its pointing to ‘localhost’). I’ve almost replace with localhost everywhere with the hostname. But still no luck. Any help on this regard is really appeciated.


#19

Hi,
I had the same problem (and still have). I posted question about it here


but so far no meaningful replay.


#20

So what is the point of having a web based control tower if you dont recommend using it via web?