Ampere Control Tower not working

Since 2 days https://ampere.workfusion.com/workfusion/dologin is not working and infact from last one week it’s working very slowly like we have to wait for around 1-2 hour for even a single process to run. Till when will we be able to use it properly?

1 Like

My team is not able to access ampere.workfusion.com since yesterday. Please resolve the issue asap, we are unable to submit assignments.

Hi @jbora and @Sarvesh_Dahiya5,

The issue with nodes was fixed. Sorry for inconvenience!

@ishmaust since the whole week I have been not able to run my business process on the ampare control tower It is very slow and giving the error, I am unable to finish my assignments

"Step name ‘Create invoice’ has failed. Reason: ‘[urn:uuid:CE5B595CC88BE98611156466893021537] robotics-flow executePlugin exception: [nodeId=null] RPA Router/Nub should return node id, but returned: {“message”:"[urn:uuid:CE5B595CC88BE98611156466893021537] Bot Manager can\u0027t find a free Bot to execute a robotic task. Please check that Bots with requested capabilties are alive using the Healtcheck API and the Bot Source size in Control Tower is equal to the number of available Bots."}’"

Hi @bafana_mathenj

The issue with nodes was fixed. Sorry for inconvenience!

Best Regards,
Ilya Shmaust

Hi @ishmaust the issue is still there.

I am trying to run a simple script but I’m getting the error below

*rg.webharvest.exception.PluginException: [urn:uuid:B39A4FC57CD6E7A7A5156829709275122] robotics-flow executePlugin exception: [nodeId=c2613fc7c56d5a11ba5c2e3a302e71dbhttp://127.0.0.1:15105] org.webharvest.exception.ScriptException:
Config line 6: script block
org.openqa.selenium.UnsupportedCommandException: unknown command: session/d93c10038129111f6af77f752f1507c5/browser/url
Command duration or timeout: 15 milliseconds
Build info: version: ‘9.2.0.4’, revision: ‘1a10eeeced’, time: ‘2018-11-29T10:44:59.891Z’
System info: host: ‘ip-10-100-26-73.ec2.internal’, ip: ‘10.100.26.73’, os.name: ‘Linux’, os.arch: ‘amd64’, os.version: ‘3.10.0-693.11.6.el7.x86_64’, java.version: ‘1.8.0_144’
Driver info: com.freedomoss.crowdcontrol.webharvest.selenium.wrapper.RemoteDriverWrapper
Capabilities [{mobileEmulationEnabled=false, extra.remote.browser.driver.address=http://localhost:20742, hasTouchScreen=false, platform=XP, acceptSslCerts=false, goog:chromeOptions={debuggerAddress=localhost:50503}, acceptInsecureCerts=false, webStorageEnabled=true, browserName=chrome, takesScreenshot=true, javascriptEnabled=true, platformName=XP, setWindowRect=true, unexpectedAlertBehaviour=ignore, applicationCacheEnabled=false, rotatable=false, networkConnectionEnabled=false, chrome={chromedriverVersion=2.44.609538 (b655c5a60b0b544917107a59d4153d4bf78e1b90), userDataDir=C:\Users\Unit5\AppData\Local\Temp\scoped_dir41644_10106}, takesHeapSnapshot=true, unhandledPromptBehavior=ignore, pageLoadStrategy=normal, databaseEnabled=false, handlesAlerts=true, version=76.0.3809.132, browserConnectionEnabled=false, nativeEvents=true, locationContextEnabled=true, cssSelectorsEnabled=true}]
Session ID: c2613fc7c56d5a11ba5c2e3a302e71dbd93c10038129111f6af77f752f1507c5
at com.freedomoss.crowdcontrol.webharvest.plugin.selenium.RoboticsFlowPlugin.executePlugin(RoboticsFlowPlugin.java:121)
at org.webharvest.runtime.processors.WebHarvestPlugin.execute(WebHarvestPlugin.java:125)
at org.webharvest.runtime.processors.BaseProcessor.run(BaseProcessor.java:127)
at org.webharvest.runtime.Scraper.execute(Scraper.java:169)
at org.webharvest.runtime.Scraper.execute(Scraper.java:182)
at com.freedomoss.crowdcontrol.webharvest.executor.LocalWebharvestTaskExecutor.executeWebHarvestTask(LocalWebharvestTaskExecutor.java:173)
at com.freedomoss.crowdcontrol.webharvest.executor.LocalWebharvestTaskExecutor.executeWebHarvestTask(LocalWebharvestTaskExecutor.java:116)
at com.workfusion.service.machine.BotRecordExecutionService.process(BotRecordExecutionService.java:171)
at com.workfusion.service.machine.BotRecordExecutionService.process(BotRecordExecutionService.java:142)
at com.workfusion.service.machine.BotRecordExecutionService.lambda$processSubmissionWithAllocationLogger$3(BotRecordExecutionService.java:112)
at com.workfusion.utils.thread.ThreadMonitoringUtils.executeWithAllocatedMemoryCallback(ThreadMonitoringUtils.java:17)
at com.workfusion.service.machine.BotRecordExecutionService.processSubmissionWithAllocationLogger(BotRecordExecutionService.java:112)
at com.workfusion.service.machine.BotRecordExecutionService.lambda$processRecord$0(BotRecordExecutionService.java:95)
at com.workfusion.utils.thread.NamedThreadTemplate.executeWithNamedThread(NamedThreadTemplate.java:10)
at com.workfusion.service.machine.BotRecordExecutionService.processRecord(BotRecordExecutionService.java:95)
at com.workfusion.service.machine.thread.RecordProcessThread.run(RecordProcessThread.java:28)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)
Caused by: org.webharvest.exception.PluginException: org.webharvest.exception.ScriptException:
Config line 6: script block

this is my script

<?xml version="1.0" encoding="UTF-8"?> <![CDATA[
			openChrome("http://mail.google.com")
			//chromeWindow = driver().getWindowHandles()[0];
			log.warn("chome opened");
			
			]]></script>
	</robot>
</robotics-flow>	

Hi @bafana_mathenj

You should add export tag and use open() function instead of openChrome().

Hi @ishmaust

May you please check the ampere instance again it is too slow, My team and I cannot even complete the assignments. A single click from control tower takes about 5 to 10 minute to respond.

Please help it’s very inconvinient for us we need to get certified ASAP.