Automating the Business Task - Course Assignments

I am not sure what you mean? Could you send a screenshot of it? Thanks.

@januscxakpyOht, see the below screenshot:

The ‘data’ table has the contents of the excel. To get each record I use the ‘col’ variable (the variable that gets each value of the list), not as ${data[0]}, ${data[1]} etc.
Hope the screenshot clarifies.

That worked perfect. Thank you so much for your time and help. You are a champ. :slight_smile:

You’re welcome :grinning:
Have a nice weekend!

Assignment 6 scroll to image OCR error

I am having trouble with the OCR function, see link to video. It seems pretty streight foreward but I can not get the OCR to work. (I have even tried to just use it on a notepad file without luck)

Please let me know what I am doing wrong. Thanks.

(solution: updating to newest version made the OCR work)

@januscxakpyOht The problem isn’t your OCR action it’s your installation, in one of the lines in the error it says that the OCR licence file is not found.

Are you running version 1.1.8 ? If so the OCR licence ran out for that, 1.1.9 was released yesterday, download that version and upgrade.

If you are running 1.1.9 already, perhaps try re-installing. I’ve just removed 1.1.8 from my system, installed 1.1.9 and run my recording for assignment #6 without a problem.

thanks… that worked.

Assignment # 3 Google Forms

Mprateek: Assignment 11: How did you open the files (offers) so OCR could read them? I have tried " Get folder content" and then loop OCR for each in the list without luck.

When I press the link in academy I am asked to login but none of my logins work there. Do I need a special login for that link? (link: )

This is the link I can not login to:

“Guide: Effective XPath
Click link to open resource.”

Figured it out :slight_smile:

Petro Didukh - Assignment 10: Web Automation and Excel

Assignment 5: Google Form (loop)
Recorder table is used as suggested in assignment description. When these values are used by the script to populate text boxes at the form, they are enclosed into square brackets by default. Please see the video for details:
Please advise how to get rid of the square brackets.

Update: found some explanation here: Foreach loop with index
Agree with other comments that such behavior is counter-intuitive.

Assignment 11: Desktop application automation

Assignment 12: Web data parsing

Assignment 3 #rpa-express #automationacademy

Assignment 4 #rpa-express #automationacademy

Assignment 5 #rpa-express #automationacademy

Assignment 6 #rpa-express #desktop-automation

Assignment 7 #rpa-express #automationacademy