Backup - Save as did mess everything up

rpa-recorder
backup

#1

My recording has worked well in RPA Recording, but now it stopped working in a stepp where it should click on the web.
Although it works with 3 similar pictures before.

Before I tried to troubleshoot it all, I made the mistake of trying to make a backup by choosing “Save as”. Now basically, nothing works, and I can not open the old script.

I show a screenshot, where I think the old one is located, but I do not seem to just click on it to enable it.

There must be something I do not get about how the projects are saved.


#2

@michael_larsso
Hi Michael,
If you close the backup recording, can you open the original file?


#3

I might try that on monday, thanks!
:star:️:smiley:


#4

Hi Michael, did you try this?


#5

No, but I was about to try it today.
When I realized that the images was gone, in the back up copy.
So now I try to recapture the imgaes, but it crashed.
Then other stuff interupted me.
Thanks anyway for your suport!


#6

I now replaced all images and it worked.
There are like 10 of them in my script.
Some worked and some did not work, do not know what hapend.

Do you know how I take a backup on the whole projekt, and save somewere else.
“Save as…” did seem to mess everything up.

Thanks ashapkina for your support!


How do I backup and restore recordings in RPA Express?
#7

Michael, glad it got resolved.
We will look into the Save As issue and how we could change it.

For backup, it is better to just copy the whole folder with the recording. If you copy the folder with the variables file and the images, the recording should open and work fine. If you want to work with both the original and backup .rpae files at the same time, just rename one of them.


Copy a script to a (Bot) computer to another one
Copy a script to a (Bot) computer to another one
#8

Where do I do that?


#9

All recordings are located at C:\Users%username%\workfusion-workspace\rpae_project.


#10

Thanks now I find it.
Hope I do not have to try to activate it.

It was in:
C:\Users\MiLarsso\workfusion-workspace\rpae_project

That you should probably automate at bit more like an “export projek backupt”!

:grinning:


#11

I use the “export - as file” function and export the whole rpae_project content to a different location. Does that have the same effect?


Undo deleted script
#12

Yes, it you need to copy it to a new location, it is actually a much better way to do it.
But it won’t allow to save the copy in wf-workspace. In this case you need to copy/paste manually. @michael_larsso I was being stupid, you can copy it directly from the media files panel, no need to go to the file directory.


#13

Maybe you should do a video about it and put it in the help menu, it is kind of important to get it right. It is not like it use to be, “Save as…” usually saves the whole project in most programs.


#14

Yes, good idea. :+1:t3: Will do