Batch file not executing


#1

I am trying to execute a batch file.
The file is being launched but not executed.

Please tell me how can I fix this.


#2

Hi Nishant,
What action do you use to execute the file? Please share the recording or a screenshot.


#3

Hi Asha ,

Thanks for replying.

I have uploaded a screen short of the flow where it is showing green against the operation.

But the file has not been executed .

As in the batch file is for clearing a directory in a file system, but the operation is not being done. Are their any other steps required for the execution of the file ?


#4

Hi Nishant, it is possible that it just doesn’t have enough time to execute before the recording stops.
Try adding a Wait action after you launch the .bat file.


#5

It’s still not working. Any other ideas??


#6

The .bat file is always executed duly when launched manually, right?
What time-frame did you setup for the Wait action?


#7

Yes , the .bat file executes.

I had set it up for 1000 ms .

Even after setting it up for more time than that , still it’s not executing.


#8

Probable reason could be, the bat file hasn’t been executed as Administrator.

Check by manually executing bat file as administrator and non-administrator and check the difference if any.

Workaround: keystroke Win+R and type the full path to bat file and launch it from Run.

Thanks,
Kishore


#9

The batch file executes correctly when executed as non-administrator.


#10

@nishant_k_kuJU Does the file you tried to execute open cmd? If it does, it might be related to this issue: Not starting * .bat file


#11