Bot Execution Failed

Hi All,

Getting below error while running the BOT.

Restarted the machine and Workfusion , cleared temp files and cookies, same error.

Please share the code you are trying to execute.

Hi Alesia ,

Sure ,
Now getting this error message -

uploading the code.
for upload.txt (23.9 KB)

Earlier the BOT used to run for the whole night ,but now it is crashing after 15 20 mins.

Please help to check

This is not a bot task, this is an rpae file.
To export it to bot task, you need to press Export code - Export code to Bot Task on the menu panel.

Could you play the recording and show which action fails?

Ohk , please check the attached XML file.

Ichamp_Test_bot_task.xml (17.8 KB)

When did it stop working? After update to a new RPA Express version?

Also, did you change the code in bot task manually?

Hi , morning ,

No , we did not updated the RPA Version , nor the BOT Task :slight_smile:

It was working fine for a month but suddenly it stopped working.

Please share the version of RPA Express that are you using and the version of Chrome browser.

Hi , Version 2.0 Beta. workfusion RPA express.
and Chrome browser - Version 71.0.3578.80 (Official Build) (64-bit)

Alesia , unable to start the BOT now , getting stuck at Selenium Capabilty Plug in

Try updating Chrome to the latest available version and updating the Chrome driver.
Here is the instruction on how to do it: https://kb.workfusion.com/display/RPAe/Troubleshooting#expand-ErrorexecutingWebElementAction

Also, your recording has a weird structure, for example, you have Open website inside Open spreadsheet action, which is not allowed, and you have click on XPath outside of the Open website action.

image

Hi , thanks for replying.

The above Format i know is bit ugly , but is working fine…

Let me update the Chrome browser and update you the results.

1 Like

Also the same BOT is running fine on my system with the same Chrome Browser version but not running on another machine.

Chrome broswer Version 71.0.3578.80 -> my machine.

And both machines have the same version of RPA Express installed?

Hi dear , the issue has been resolved.

I have transferred the chrome driver file to my other system , bang , BOT started to work fine.

thanks alot for the guidance.

3 cheers for you

1 Like

Glad it got solved :grinning: