Bot is unresponsive

Hi, we have five bots, but only four of them are responding. The unresponsive bot restarts along with the server like the rest of the bots and when closing this RDP session it relaunches like the rest as normal. The only difference is Bot 1 will not pick up any tasks from the control tower. Any suggestions?

Hi @martina_r. Please advise your RPA Express version from Control Panel - Programs and Features. How long does this issue occur? Did you make any changes in server configuration? Did any security policy change?

Our current version is 2.3.0.1236
Server configurations aren’t any different from the default values taken from Knowledge Base aside from the control tower’s address. No policy changes were made to the bots–if there were, the bots are part of a group policy so it should have applied to all 5, I would think. Also, we’ve experienced this issue since activating RPAExpress. Bot 1 has never picked up a task since we first got it up.

Thanks Martina.
Could you please send me files from C:\RPAExpress\Agent\Logs? And please advise when you installed RPA Express at the first time on server, what version and how much bot count did you enter during installation?

RPAExpressAgent.zip (22.2 KB)
We first launched it some time in March, I believe. Earliest timestamp I can recall is March 18, 2019. We specified 5 bots at minimum upon installation.

Thank you. Could you please clarify when this issue occurred? Did it work previously and pick up all tasks?

it never worked previously to pick up all tasks.

Could you please send me the following logs from folder C:\RPAExpress\RPA\logs\ for last week, for example:
rpa-hub-<TimeStamp>
rpa-node1-<TimeStamp>
rpa-node2-<TimeStamp>

rpa-hub-2019-06-17.0.zip (723.1 KB)
Here’s one log from each node from the previous week. There weren’t any logs for rpa-node1, however. only the hub, 0, 2, 3, 4, and 5.

It’s strange. Could you please send files below?

  • RPAExpress.Agent.exe.config from C:\RPAExpress\Agent\
  • screenshot of content in folder C:\RPAExpress\RPA\rpa-grid\
  • one more point. Please go to Windows Task Scheduler and find task named - WorkFusionRPABot1Logon. Please send me screenshot of its property tab “Actions”. You should see in Action column - Start a program and in Details - specific command. It should be almost the same as in other WorkFusionRPABot[x]Logon tasks.

Thank you in advance.

Aha, I see something funny.
Bot1 has the same actions as the other logon tasks image
But I did notice something different for Bot1 that’s the same for the others:

image

Maybe it has something to do with this difference? I can send a ticket to our local IT dept about it.

In the meantime, here’s the rest of the data you asked for: agent.zip (45.7 KB)

Thanks for checking tasks. I see now what causes the issue. For some reason you have another user account in task settings. I don’t know how it could be, but usually all WorkFusionRPABot[x] should work under local user accounts on the same server. You can check which users you have in your server, should be like on my screenshot, but for 5 users:
image

something must have happened when our systems team initially set it up; I have something a little more convoluted looking on our end:
image
I’ll add this information to my ticket for the local support team and keep you updated on any improvements.

2 Likes

Thank you!

Hi @Lera,
Problem solved! Our local support team noticed that Bot1 had an incorrect login script and corrected it. We now have five bots online and working :smiley:

2 Likes

Glad to know, Martina! Thanks for the update!