Business process failed to run in Control Tower but works fine in RPA Recorder

business-process
issues
control-tower
#1

I have created a business process. It works fine if i run it in RPA recorder but when i run it in control tower it fails. The progress is 0%. Im sure the script works fine since it did’nt had any problem while running in RPA recorder. I wanted to schedule a task. Can u please suggest what to do.

#2

@ajay_gopikrish
can you share your recording for investigations?

#3

RPAscript.txt (9.6 KB)
I coudn’t share the exact links for the websites and also there is a vb script which is run from the Command Line Interface since it’s confidential. The script works fine in RPA recorder. But in control tower there is no progress. Please Help.

#4

@ajay_gopikrish,

please add double backslashes for all the file paths:

C:\\Program Files (x86)\\Google\\xxrome\\Application\\xxrome.exe
#5

Hi

I am also facing the same problem, this solution is not working.

1 Like
#6

Same here. Using double backslashes but not working yet.

#7

Hi all,
I think in groovy script you have to use double backword slashes for all the anchor images and you have to put all the script inside robotic- flow tag,inside robot tag…it should work…it worked for me…Create one business process in control tower sepearately,copy paste your groovy script and do above steps…It should work…
Thanks.
Sharad Kumar

2 Likes
#8

I can’t find the groovy script. Only the rpae script is there. In one project the groovy script is available along with the rpae.
I don’t know why the groovy script is not found in other projects. Please Guide me.

#9

i tried it and still the process fails to run. On clicking run in control tower nothing happens.

#10

Hi ajay,
In rpa recorder one option is there export as groovy script…Copy that groovy script and create one business process in controll tower and paste that inside robotics-flow tag contains one child tag robot tag there you have to paste your groovy script…and remember for your anchor images you have to give complete path where your anchor images saved…Try it.
Thanks
Sharad Kumar

2 Likes
#11

Im knew to this. I created a process but where to find the tags and where to paste the groovy code. Please help!

#12

Hi ajay,
Read this topic how to get groovy script.


after that create one business process in control tower and make sure your all components in rpa recorder up and running…and remember give complete path of anchor images with double backword slash or one forward slash
Then copy groovy script and paste it here…Try it

<?xml version="1.0" encoding="UTF-8"?>
#14

I made changes to the groovy script and copied. But where should i paste the modified groovy script?

#15

Hi ajay,
https://forum.workfusion.com/t/groovy-script-in-control-tower/9764
Read this and remove all the code from script tag paste your groovy code here and remove all codes from export tag also…Then create a new fresh business process in control tower and put this all the codes there and try to run but for anchor images give full path then only it will work.
Thanks
Sharad Kumar

#16

so what u suggest is i must remove the whole code inside from the .rpae script and replace it with the groovy script.

#17

groovy script paste it there…inside script tag…All process you have to by creating new business process in controll tower…

#18

Hi Sharad, im still stuck with this. Can u give me ur email id so i can know specifically what to do and we can get in touch.

#19

hi ajay,
I dont have access to use gmail ids.
ping me here in message we will discuss here…
Thanks

#20

RPAscript.txt (9.6 KB)
This is the rpae script that i have. So u want me to include that groovy script in this by including the script tag and export tag.

#21

Hi ajay,
when you are creating any recording it will automatically create groovy script…you can find groovy script by opening recording in RPA Recorder and use export as groovy script option there…Then you will find groovy script…Then create one business process in control tower and paste that groovy script inside robotics-flow inside robot tag inside script tag is there…There you have to paste your groovy script…Use fully qualified path of anchor images…at last export tag is there after closing robotics-flow tag let it be.Dont do any thing with export tag…In forum you will find robotics-flow syntax anywhere in this forum already above i posted
Thanks
Sharad Kumar