Business Process not running from control tower


#1

Dear Team,

I am using 1.1.4 version and I have created a script in which I am taking data from excel and inputting in SAP system , which is working fine from RPA recorder. but script is not running from control tower after published.

Even I have tried your template (Win7_Win10_HelloWorld.rpae) also but getting the same problem.

Request you to please provide me the solution.

Regards,

events_2017-08-11 03-31-32.xlsx (9.9 KB)


#2

@sarveshmishra,

Thanks for reporting this issue. It appears that something is wrong with the For Each action.

We will investigate this and fix when possible.


#3

Thanks Team, request you to please update me on my request.


#4

@sarveshmishra, we are gonna make a patch this week, but there is a workaround for you not to wait for a new version:

You need to inspect all the For Each loops and create their temp variables in the Recorder Variables panel. For example:

For each ‘row’ in 'table’
For each ‘item’ in ‘row’

You need to create 2 string variables: row and item.


#5

Thanks team, but still getting same error…


#6

Dear team, can you update me on my request.


#7

please post here your zipped recording folder


#8

PO Creation SAP.zip (847.6 KB)

Please find the attachment and do the needful.


#9

as I see, you haven’t created the item variable in the Recorder Variables panel:

But we have released a hotfix for your problem - so you can just download and install a new version - it is accessible by the same link. Thanks.


#10

is this step compulsory for every for each loops?


#11

not anymore. In new version you do not need to create For Each loop variables.


#12

Dear Team,

Request you to please let me know that our data will be secured or not in workfusion RPA (like Data theft, hacking and cyber attacks).

Regards,


#13

Dear Team,

Can we publish and deploy the business process (in .exe/any other format) on users machines?

Regards,


#14

@sarveshmishra,

please use separate topics for questions not related to the current one.

see our guidelines - WorkFusion Forum Guidelines


#15

Is this the same hotfix for the OCR issue or another hotfix release?


#16

@azinchuk
I create a WF script and try to push it into control tower.
It successfully publish to control tower and when i log into the control tower Business process is not displayed :frowning:

Restart WF RPA express and Also restart the services as well .


#17

click the Advanced checkbox in the filter section and make sure all filters are disabled.