Business processes run on server machine, not on workstation


#1

Hi,

I have installed 2.0.1 and tried server component. But the issue I am facing is all the business processes which are deployed from workstation are running on server system.

In detail, I have installed both workstation and server on one machine and only workstation on other machine. I have published the code from workstation machine to server. When I run the business process from workstation machine’s control tower the code is getting executed on server machine. I think the code should be executed on workstation machine.

Please help me on this.

Thanks,
Siva Ramakrishna Mangisetty


#2

Hi @sivaramakrishna.mangisetty
Yes, that is the correct behavior.
All scripts are executed on the server machine, and workstations are only used for developing scripts.


#3

Thanks for quick reply!

Just want a small clarification on this. I have 3 machines with workstations and Businesses processes are deployed to server, if I run all Business processes at a time they are executing one after another.

Is there any way that all the processes can run in parallel ?


#4

Do you have multiple bots installed on the server?


#5

Yes, I have one workstation machine connected to server machine through IP address. Sever machine has both workstation and server component. Is there any way to run two business processes in parallel from server machine and workstation machine.


#6

When I open WorkFusion, I can see 4 RDP’s connected automatically where I can’t open WorkFusion. If you could provide some info on this that would be helpful.


#7

RDPs are used only for running business processes, you don’t need to start RPA Express there.
If you have several remote bots, the processes should be played in parallel when started from the Control Tower.


#8

I have scheduled 3 Business processes at same time out of which 2 processes ran on two different RDP’s and one ran on server machine. Though there were 4 RDP’s opened one business process ran on local server machine.

Could you please guide me on how to make all the business processes run on RDP’s.


#9

The business processes are executed on the available nodes, and these will not necessarily be remote bots.If you don’t want the local bot to be used, you can:

  • go to Bot Manager and stop rpa.bot
  • reinstall RPA Express on the server machine (install only the server component)

#10

Thank You! this helps.