Can a robot find a particular sheet in an Excel book?

Hi.

I tried to copy data in [Excel action] but it was copied as [String].
※ I want to copy in [Value] data type.

So I want to launch Excel from the Launch Application action, move to a specific sheet and copy the cells.

Is this still valid?
It did not function properly in my environment.

Hi @Moriya_akira, did you get an error when you tried this approach?

If you can inspect the Excel sheet and the Inspector sees the element as on the image below, it should work
image

Also, you can check if the selector you use is correct following this guide: https://kb.workfusion.com/display/RPAe/Inspector#Inspector-TestingSelectorsSearch

The element “Sheet tab” was not found.
Where is it? I’m glad if you can tell me

environment
RPA Express 2.3.3
Office 2016 Pro Plus (VL)

It looks like it might be related to this issue

Could you share what version of Excel you are using?

Excel:Microsoft Excel 2016 MSO (16.0.4849.1000) 32bit

1 Like

Thank you @Moriya_akira. Seems the same issue with Excel 2016 version.
As soon as we have an update about it, I’ll share here.

In the meantime, try switching to the required sheet using Go To window

1 Like