Cannot capture elements with xpath in Java Swing based application

I have issue with Workfusion RPA express (2.3.1) for not capturing any Element from the Java Swing based application window. It only captures main window then images for the interacted elements and x,y coordinates.

Do you try to capture the elements by recording your actions?

Try inspecting the application using Inspector. Does it see the elements in this case?

@ashapkina, I tried both ways, recording only captures the window then objects with images and x ,y coordinates. Inspector does not highlight any thing. The app we are trying to automate is BURP professional version 2.3.1 to kick off the scans. Workfusion was recognizing objects on earlier version.

Try running RPA Express as administrator, or updating to the latest version - 2.4.

Also, in which version was Inspector able to see the elements of this application?

@ashapkina That was application BURP’s version 1.7.

So it worked with the previous version of BURP application?

Got it. I though initially that an earlier version of RPA Express could see the elements in this application.

@ashapkina that is correct.

Did starting RPA Express as administrator help solve this issue?