Cannot find active server profile

Upgraded a server from 2.0.1 to 2.0.5 today. Now, it appears I’ve lost all my settings in Studio. When I attempt to launch a recording I get the error ‘Cannot find active server profile’. The same occurs when I attempt to publish to the server.

Error detail below:

com.workfusion.studio.recorder.bridge.profiles.ServerProfileStorageException: Cannot find active server profile
  com.workfusion.studio.rpa.recorder.player.exception.PlaybackFlowRunningException: com.workfusion.studio.recorder.bridge.profiles.ServerProfileStorageException: Cannot find active server profile
      at com.workfusion.studio.rpa.recorder.player.PlaybackProcess.start(PlaybackProcess.java:96)
      at com.workfusion.studio.recorder.editor.action.AbstractPlayRecordingAction.run(AbstractPlayRecordingAction.java:73)
      at com.workfusion.studio.recorder.editor.action.PlayRecordingAction.run(PlayRecordingAction.java:23)
      at com.workfusion.studio.recorder.editor.action.RecorderAction.run(RecorderAction.java:28)
      at org.eclipse.jface.action.Action.runWithEvent(Action.java:473)
      at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:565)
      at org.eclipse.jface.action.ActionContributionItem.lambda$5(ActionContributionItem.java:436)
      at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
      at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)
      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
      at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4236)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3824)
      at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
      at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
      at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
      at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
      at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:138)
      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:498)
      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
      at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
      at org.eclipse.equinox.launcher.Main.main(Main.java:1492)
  Caused by: com.workfusion.studio.recorder.bridge.profiles.ServerProfileStorageException: Cannot find active server profile
      at com.workfusion.studio.rpa.preference.profiles.ServerProfilesServiceImpl.getActiveProfileName(ServerProfilesServiceImpl.java:63)
      at com.workfusion.studio.rpa.preference.profiles.ServerProfilesServiceImpl.getActiveProfile(ServerProfilesServiceImpl.java:56)
      at com.workfusion.studio.rpa.recorder.player.PlaybackDefaultVariables.getOcrApiUrl(PlaybackDefaultVariables.java:30)
      at com.workfusion.studio.rpa.recorder.player.PlaybackDefaultVariables.<init>(PlaybackDefaultVariables.java:17)
      at com.workfusion.studio.rpa.recorder.player.PlaybackProcess.doStart(PlaybackProcess.java:123)
      at com.workfusion.studio.rpa.recorder.player.PlaybackProcess.start(PlaybackProcess.java:89)
      at com.workfusion.studio.recorder.editor.action.AbstractPlayRecordingAction.run(AbstractPlayRecordingAction.java:73)
      at com.workfusion.studio.recorder.editor.action.PlayRecordingAction.run(PlayRecordingAction.java:23)
      at com.workfusion.studio.recorder.editor.action.RecorderAction.run(RecorderAction.java:28)
      at org.eclipse.jface.action.Action.runWithEvent(Action.java:473)
      at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:565)
      at org.eclipse.jface.action.ActionContributionItem.lambda$5(ActionContributionItem.java:436)
      at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
      at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)
      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
      at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4236)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3824)
      at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
      at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
      at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
      at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
      at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:138)
      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:498)
      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
      at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
      at org.eclipse.equinox.launcher.Main.main(Main.java:1492)

Hi @sbeauchem

Does it show this error when you open the server profile?

If it does, please try this solution:

  • close Studio and exit from RPA Express
  • delete folder C:\Users%USER_NAME%.eclipse
  • start RPA Express.

The server profile should appear in the preferences. If the fields are not filled in you can fill them in manually as described here https://kb.workfusion.com/display/RPAe/Preferences

1 Like

This corrected the issue. Thank you!

1 Like

Glad it helped :slightly_smiling_face:

Hi Alesia,

I am having the same issue on my bosses laptop. I downloaded the latest today, after already uninstalling the previous version.

What is the file path exactly? C;\Users.eclips? If so, there is no such folder, so it’s not possible to delete.

I will not be able to check anything until Thursday, but I wanted to get this out to you for some ideas.

Thanks for your ALWAYS great help!!!

Jim

Hi Jim, there should be .eclipse folder in this location: C:\Users\username

Great! Will check tomorrow!! Thanks again Alesia!!

1 Like

Hi Aleisa!

The folder does not exist on the laptop. And when I close all of WF RPA, and reopen, it does not get created.

I tried following the manual steps to add a profile, but the screen is black except for an “Apply” button, similar to another poster, earlier in this chain.

Can I get the manual way to do this explained please?

Thanks!!