Cant double click on an image

Im trying to double click into an image where I need to select a file from an image… I single click the image before and try to double click it afterwards for selection but it doesn´t do anything… It doesn´t show any error while running though.


And this is the image i’m trying to double click:

Hello @Josemota,

The bot can’t recognize the picture, as there are 4 similar icons.
image
You should capture the image with the name of the file and use double click:
image
It should help.

It recognizes the image because i’ve put on the first single click the grey area above.
It was working fine until suddenly it stopped working.
If I open a new recording and replicate this steps only, it work fine.

Have you tried to change the captured image? Maybe it will help to solve the issue.
Also could you please clarify, what happens after it stops? Any exception or error?

Yes I tried changing the image but it doesn´t work… and the flow doesn´t stop, it does not show any exception or error after it finishes.

So the script continues to run skipping this particular action (30) or the script continues to run but nothing happens after it doesn’t double click?
Could you also please clarify your RPA Express version?

It continues running, skupping the particular action (30) i´ve made a workaround for that specific action but now it happens the same thing with a Switch Window action. I got version 2.2.

And another mistake is when I do a Keystroke, the bot changes windows…

Hello, the probable reason is that it the keyboard action logic has been changed since version 2.2 of RPA Express. It is required to switch to the window you need to type the text before typing.

1 Like

Hi @Josemota is double-click the only way you can open the file? Can you open it using win+r and typing the path to the file?

I could try that, but why would I have to do all that workaround for only 2 clicks?

It was just an idea for a workaround if the mouse click keeps failing. But if it works, you are right, there is no point of doing it.