Click Mouse - 'On Image' Stopped Identifying Image


#1

Last night when I created a process I didn’t have any problem identifying the images and my process worked very well. Today when I try to run it, it isn’t recognizing any of the images I had saved. I thought it could be related to using my laptop screen last night and monitor on my docking station today, so I recaptured the images. Below are the two images from screens with a different resolution. As you can see this should not have affected image recognition. It still will not recognize the images. I have had this happen before and still cannot determine why. Any help would be greatly appreciated.


FindElement by Image - Image does not found
#2

@CIverson_Terex - you can do the following:

  • lower the image similarity option:

OR


#3

I have done both of those as well. All of my images stopped being identified. There were two that were very small areas and would not be identified. When I undocked my computer and ran the process it ran on my laptop screen just fine. Why do the images stop being recognized, even if I recapture them, when I am on a different screen?


#4

@CIverson_Terex - are you using the latest 1.1.1 version?


#5

I am also facing the same issue, images are not getting recognized and tried the both ways (decreased the matching threshold, created smaller screenshots) still image is not getting recognized. Please let me know what should be done.


#6

@Harshit_Jain,

This is all we can recommend for now. But in next releases we are going to introduce the Object Recording functionality which will solve the issues stated above.

Thanks for your information.


closed #7