Clipboard malfunction when running multiple bots simultaneously

Hi
Significant bug found while running copy and past to clipboard on multi-bot through control tower.

Suppose that there are two processes running simultaneously. The first process is assigning “OO” to the clipboard and then put the value to the variable named T1 then print it to the note pad. By repeating this step for 200 times, we expect the “OO” to be printed in the note pad for 200 times.

The second process is assigning “XX” to the clipboard and then put the value to the variable named T2 then print it out to the note pad. Repeating this step for 200 times as well with only the “XX” is to be expected to be print out.

By running both processes concurrently in the control tower, we found that the result are not what we are expect. There are some mixing in “OO” and “XX” in the variable both T1 and T2. Meaning that they are sharing the same clipboard when performing copy and paste action. Can anyone from WorkFusion solve this issue?

Sakda

Hello Sakda.
Could you please advise your RPA Express version? You can check it in Control Panel - Programs and Features.
Also please advise system properties of you server: OS, OS Type, CPU, RAM, etc.

The version is 2.1.1

OS is Window Server 2012 R2

Physical server : Intel ® Xeon® Gold5115 CPU@2.4 GHz (40 processors) Ram 256 GB SSD 4 TB

Thanks. And how much bots do you have?

We activate all 16 bots. But during the test run for only 3 bots, the bug as indicated above was found so that we can not do testing for more processes concurrently. Thanks.

@sakda - please check that your bot RDP files have Clipboard checkbox unchecked:

image

Hi azinchuk,

This is not resolve. The result of both processes are still mixing.

Best,

so it is not a clipboard problem.
By default all records from all business processes are executed on a random Bot (RPA node).

If you want to keep using random Bot execution, you need to add Clear Clipboard action at the end and beginning of each recording.

If you want to route tasks from Process 1 to Bot 1 and tasks from Process 2 to Bot 2, you need to use custom capabilities - https://kb.workfusion.com/display/RPA/RPA+Nodes+Capabilities
But they are supported only in Code perspective.

Hi Azinchuk,

It is the clipboard problem. You can test it by only create the two processes running concurrently as i mention earlier above.

Best,

The first process is assigning “OO” to the clipboard and then put the value to the variable named T1 then print it to the note pad. By repeating this step for 200 times, we expect the “OO” to be printed in the note pad for 200 times.

Hi @sakda

does the bot do all these actions in the same bot task or in separate bot tasks?
Maybe, you could send us these 2 business processes so we test them?

You can read how to export a business process here.

have you added the Clear Clipboard action at the beginning and at the end of each Bot task?

These actions done by separated tasks. Sure we will send you both two process for your testing.

Yes, we always do clearing before copying the new value to the clipboard.

@sakda - your both tasks do not contain Clear Clipboard action

image

No, this is not solve.

1 Like

Hello @sakda.
I tested with the current RPA Express version 2.2.2. I was able to reproduce this issue in case when RDP setting “Clipboard” is ticked. When it’s off, both files contain only their rows.
Please check how this option is configured for .RDP files in folder C:\RPAExpress\RPA\wfagent\rdp (right-click and Edit). You should see the following picture:
image
If you have “Clipboard” is unticked and you still have the same issue with your version of RPA Express, I recommend you to install/update the latest one (2.2.2) and check with it.

1 Like

Hello @sakda. Did this solution help you?