Clipboard to list variable not working as expected


#1

Hi
I want to fill a list variable from clipboard. The content of the clipboard is a list of 32 file paths. When I do the “test setting” operation in the clipboard activity there seem to be 32 lines created in the list but without content:

In the next step I want to get the number of rows in the list using expression value:

But when I execute the process the value that is put into my numbfiles variable is always 1 and not 32 as I would expect it to be.

Any hint?
Thanks!


#2

Hi, @timriewe
Try to change Line separator


#3

Hi @mzhalniarkevich
I tried that and got the same result as with windows row seperator. No luck.


#4

According to your screenshot you are using table variable, and you have a list Data

Try t sect List variable instead, and set Row separator as Linux / MacOS line break (LF)


#5

This worked! I had tried the list variable before but not in combination with the Linux/MacOS linebreak.
Thanks @mzhalniarkevich !
The process for counting the number of rows works correctly and returns the expected 32. However, when testing this list variable only 1 row is shown in the preview.
Thats a bit confusing.

Anyway, topic solved.
Kind regards


#6

If you place data to list from clipboard, right now you need to know the exact size beforehand and create list varible with the same size.
F,e you will have 10 records in this list: