"Connecting to server..." does not finish

Hello,

I haven’t used RPA Express for 3 weeks more or less and now that I opened the program it shows the message that is being connecting to server but I have waited for 3 hours several times and it just doesn’t finish. I have uninstalled and installed the program, restarted the PC, etc. and it just doesn’t work. What can I do?

Best regards

Hi @smariscal.
Could you please provide a screenshot of this error message? Which version did you install? You can check it in Control Panel - Programs and Features.

Hello Lera,

The Version I have installed is 2.3.1

I downloaded this version from the portal yesterday because of the issue I mentioned that it was not connecting. When I was on the training on site it happened the same but I uninstalled and installed the program and worked, but now, it just doesn’t connect to the server so I can not run the bots to review if they work properly before submitting them to Control Tower.

Regards.

The complete version numbers are 2.3.2.1287 as per the Programs and Features window :slight_smile:

Thank you. Could you please provide a screenshot of this error? And also please provide full screenshot of this window Window > Preferences > WorkFusion Studio > Server Profiles.

Hello Lera, this is the screenshot of the window requested. Yesterday I left my PC working on the “Connecting to server…” and after I don’t know how many hours, at last, it was connected, but I think something is wrong due the time taken. I’ll be aware about any workaround to fix this :slight_smile:

Thanks for the information. Do you set up server components to “Manual Control” or “Always Running” option? Also I would recommend to close other unnecessary applications before starting RPA Express.

Hi Lera,

Sorry for the late response. I haven’t changed any value on that Window, by the way, I don’t know where I can find it. The preferences are the ones that were installed by default, so, in case that I need to change something there, could you please let me know how I can get there?

Thanks in advance and best regards!

Thank you. Could you please send me logs from folder C:\RPAExpress\Agent\Logs?

Uploading Logs.zip…

Hello Lera,

Attached you can find the file requested. Best regards!

Logs.zip (4.1 KB)

Thank you. These logs look fine. Could you please show C:\RPAExpress\Studio\logs\ studio.log as well?

studio.log (118.6 KB)

Hello Lera, here it is :slight_smile:
Let me know if I can help with something else from my side.

Best regards!

Thank you, @smariscal.
Could you please advise which version did you download from our web-site? Was this Free or Free Trial?
image
I’m asking because according to your logs it looks like you don’t have Control Tower installed on your PC. But for some reason you have links in Preferences window. Did you add them manually?

Hi Lera,

I’m not sure but I think I installed the PRO version. By the way, I have uninstalled the previous version and I’m installing the PRO version again. I’ll let you know about the results once the installation completes :slight_smile:

Best regards!

1 Like

Ohh, sorry, about the last question regarding the links on the preferences window, I didn’t add them, they were automatically generated.

Untitled

Hi Lera,

Guess what? I have tried to install the PRO version and this issue appears every time. I have tried many times restarting the PC and the error still appears.

I’m lost now, what I can do? :thinking:

This is very common error. Could you please send all files with names start with WorkFusion_RPA_Express_<some_postfix> and have extension .log from folder C:\Users\%user_name%\AppData\Local\Temp? They can be enough huge, so please zip them into one archive.

Temp.zip (4.5 MB)

Hello Lera,

Please find attached the files requested. Let me know about any steps I need to follow in order to install WorkFusion Pro again.

Best regards,