Control tower not loading new business process

Just more of a confirmation, I am currently running 1.19, do I need to install 1.20 to create a business process in Control tower?

Hi Jason,
No, you don’t. You can continue using version 1.1.9, the functionality is not limited by the release of the new version in any way.