Control Tower will not run the process

issues

#1

Hi,

I have created a recording which deals with Outlook and Excel.
It works perfectly while running from the Recorder, but I get an error while running it from Control Tower.
I have tried the proposed solution (replace \ with \ in file paths, etc) with no luck.
Here is the error:

[urn:uuid:65761AAFD1E57B84F6152025693373745] robotics-flow executePlugin exception: [nodeId=http://127.0.0.1:15410] com.workfusion.studio.rpa.recorder.playback.PlaybackException: Error executing TemplateAction[templateName=ExpressionValueAction.ftl,id=20,name=Optional[ExpressionValueAction],parent=19,arguments=ActionArguments[listExpressionHandler.pollingInterval=[300],tableExpressionHandler.tablePushType=[AS_ROW],varName=[grouptbl],listExpressionHandler.awaitTimeout=[5000],tableExpressionHandler.targetVarName=[item],xsi:type=[recorder:ExpressionValueAction, recorder:ExpressionValueAction],pollingInterval=[300],active=[true],tableExpressionHandler.awaitTimeout=[5000],listExpressionHandler.operationType=[PUSH],delay=[0],timeoutMs=[10000],bigDecimalExpressionHandler.pollingInterval=[300],tableExpressionHandler.pollingInterval=[300],bigDecimalExpressionHandler.awaitTimeout=[5000],awaitTimeout=[5000],tableExpressionHandler.operationType=[PUSH]]]

Could someone explain what is wrong and how could I fix it?

Kind regards,
Dimitrios


#2

Hi Dimitrios, what version of RPA Express are you using?


#3

According to the error log, you have a variable “item” in your recording.
Due to some changes in Control Tower, item cannot be used as a name of a variable any more.
Change the variable name and try to run the business process again.

Please let me know if the error still occurs after that.


#4

Hi @ashapkina,

It worked like a charm :smiley:
Thank you very much for the support.

Maybe it would be a nice idea to collect all these tips (e.g. the RegEx example with /, /i not working) and restrictions (e.g. use of ‘item’ as a variable name) so some page in KB, so as anyone has quick access and solutions?
It would also save you time from answering all these questions in here :wink:

Br,
Dimitrios


#5

@dimitrios_nt Dimitrios, thanks for the suggestion.
I will update the knowledge base.


#6

Im having a similar issue.
It also works correctly from the recorder.
It ran 1 time from control tower but now it crashes every time.
I have 2 different processes that start with the same first few steps and both are crashing.


Im running version 1.4.0.

Step name ‘Linkedin broadcast verification’ has failed. Reason: ‘[urn:uuid:61B7E16F7A5BB46B31152376043215429] robotics-flow executePlugin exception: [nodeId=http://127.0.0.1:15410] com.workfusion.studio.rpa.recorder.playback.PlaybackException: Error executing TemplateAction[templateName=WebElementAction.ftl,id=40,name=Optional[WebElementAction],parent=-5,nextSibling=41,arguments=ActionArguments[varName=[linkedin_location],delay=[0],exactMatch=[true],useElementAttribute=[false],webElementLocatorType=[XPATH],xsi:type=[recorder:WebElementAction, recorder:WebElementAction],active=[true],comment=[enter location in filter],actionDetails=[(set by //input[@type=“text” and @placeholder=“Add a location”] xpath)],searchInFrames=[false],type=[SET_VALUE],webElementLocator=[//input[@type=“text” and @placeholder=“Add a location”]]]]’


#7

@ashapkina, any thoughts on how to overcome this error?


#8

@eaguirreepjIJX Could you share the details of the error that you get?


#9

The exact error message is above in my post from a few days ago.
(Control Tower will not run the process)

When I run it in control tower the process stops and restarts from the beginning. I have it set to run 10 times if there is an error and it crashes in the same step every time. The report that I get shows the same error as above listed 10 times.

That web element works fine in RPA recorder so Im not sure what I can do to change it to make it work.
The variable “linkedin_location” contains the word “houston” FYI.


#10

The action works when I use single quotes instead of double ones in the xpath: //input[@type=‘text’ and @placeholder=‘Add a location’]
To be fare, the xpath with double quotes didn’t work in the recorder for me, either.
Can you try using single quotes?