Ctrl+Alt+s conflict with robot

My program that I would like to control actually need to use the shortcut:
Ctrl+Alt+s
And it seems to work every second time or so.

I then realized that the BOT uses ctrl+alt+s as well to control the Robot when it is running, as a kind of Meta level. I now suspect that it could become a conflict here.

Sk%C3%A4rmklipp3

Hi @michael_larsso,

It conflicts with a robot only if you enter it manually. If you use this combination in Enter Keystrokes it should be fine. Just tested it with Outlook:
image

Strange then, because I have 60+ robot steps,
and the normal thing is that it stops on step 25 where the Ctrl+Alt+S step is,
if I then try it again it usually works.

Thanks any way!

I try it again today and the exact same thing.
I only restarted the script and it worked again at the Ctrl+Alt+S step, but crashed at the first try.

Hi @michael_larsso
Could you make a screenshot of your project actions flow where the issue occurs?

Hi again @michael_larsso.
I was able to reproduce the issue and it was escalated to our development team, thanks to you!
So the issue reproduces only when you launch script for first time (or any other script) and if you launch your script again, it should work fine.

I would like it to work on the first try. It would be great for me.

This is another script and it also crashes at the Ctrl+Alt+s part!
This old script used to work.

I made a GIF that shows where it crash, it is quite long (4 minutes) but it givs the best picture of what happens, I have blurred out some parts of the screen even if I do not think it was important. It shows how it crash even tough I do even less when I run the script for real, but I do restart the ERP-program.

I made a better GIF-movie like 25 MB but I could not upload it, this one has less quality but is under 4 MB.

Hi @michael_larsso That’s a bug and the script won’t run on the first try. Probably it will be fixed in future releases, as it was already escalated to our development team. For now I can recommend you to run some other script first then run this script.

Hi the problem still persistst, and has not been fixed.
It is offcourse of great hassel to us, when our ERP-system uses ctrl+alt+S to search in the menue.

Hi @michael_larsso. Yes, the issue hasn’t been fixed yet.

Some systems have a screen where you can custemize some parameters in the system.
I have no problem with this if it was left optional to quit the robot or not with short-keys. I have never used it, I press the button, but my program use ctrl+alt+S. So I think a first quick fix would be to make it optionall.