Ctrl + + in Excel does not work

Hi everybody!

I’m working on a robot on RPA Express. During its execution, this must open an Excel workbook, then it must insert a new column on the left of column A. The procedure I traced is like this:
Ctrl + Space - for select the whole column
Ctrl + + - to inser a new column, but this does nothing

I reviewed Excel documentation and my keys combinatation are right, but it seems in RPA Express just ignore them.

What can I do?

Greetings.

Hello Juan.

What’s version of RPA Express you use? Did you receive any exception during execution of your bot?

Hi, Valeryia!

Thanks for answering! I’m using RPA Express version 2.2. No, I did not receive any exception. My robot seems to execute that step, other key combinations work just fine. Also, I don’t do this from Excel controls section, I just pass a Key combination from Key Strokes section.

Thank you. Do you have a keypad with numbers only on your keyboard? I checked directly in Excel (without RPA bot) and found out that Ctrl-+ doesn’t work for me even I applied it manually. But this combination works: Shift-Ctrl-+.
Please see this article for the details: https://www.extendoffice.com/documents/excel/2465-excel-shortcut-insert-or-delete-row-column-tab.html
Let me know if that helps.

1 Like

I have a laptop keyboard, but this key combination is straight. Let me prove this alternative you offer, then I’ll let you know how it went.

Greetings

Hello, again.

I tried that alternative. Unfortunately, it didn´t work. I think, I’ve to do column insertion using images, I don’t like this way but, at the moment, it is more useful than using key combination.

Thank you.

Hello Juan.
Are you able to apply this key combination manually in Excel?

Hello, Valeryia!

Thanks again. Yes, effectively, I can use this key combination in Excel manually. That’s why it seems very curious to me.

Thank you. Can you share your actions if possible? I’m wondering how it looks like in your “Enter Keystrokes”.
By the way, did you put this key combination under “Window” actions? Like in this example:

image

Hello @jfarias.
Could you please share your actions? We would like to investigate this issue further from our side.
Thank you in advance.

@jfarias we are hoping to fix this issue with keystrokes in our April release.
For now, you can use the following workaround: after pressing Ctrl + Space to select the column, press Shift +F10 to open the context menu, switch to its window and press i to insert a new column.

Hi @jfarias did this workaround help you solve this issue?

Hi, @ashapkina thanks for your assistance. Yes, this did workaround, it is not my ideal solution, but, for now it is sufficient. Again, thank you.

Greetnings

1 Like

Glad it helped :slightly_smiling_face:

Hi @ashapkina,

I met with the same problem as jfarias. Tried to use Ctrk + + but doesn’t work.

I have then tried your workaround but i am stuck at step 5, there is no Net UI Tool Window in my open window list to select from. I keyed in the text but my bot can’t recognize it.

Could you please help?

Hi @wpeng use the Recorder to capture the correct window:

image

Press “Insert recording”

  • click on the column
  • press Ctrl + Space
  • press Shift +F10
  • click anywhere on the opened window - the recorder will capture its name automatically.

Thank you @ashapkina, it solves my issue.

Is there any update on the resolution of (Ctrl + +)?

1 Like

@wpeng sorry, not yet. I’ll let you know as soon as there is an update.

I’ve had this problem with ctrl + enter as well so I wrote a simple script to programmatically trigger the key combination. This can become another workaround for ctrl + + until they fix this bug in WF studios.

@CustomScriptAction()

def customScript() {
    String keyComb = Keys.chord(Keys.CONTROL, Keys.ADD)
    sendKeys(keyComb)
}
2 Likes

Works perfectly @tinwy :smiley: