Desktop Automation 2.3

Hi Team,

I was developing desktop automation on 2.2 version of RPA Express and everything was working fine.

2 days back I upgraded to 2.3.0 version and suddenly my code started behaving differently.

Issues.

  1. The application starts and then disappears, and after sometime, I can see that application in background processes in task manager.
  2. In my desktop application, I use one window to login and after that, I click some element and try to open another window. But in this newer version, I am not able to open another window.

Regards,
Nitin Rathod

Hi @nitinrathodHSy

As I understand, you are talking about RPA Express application in the 1st question. There is no Tray Menu in version 2.3, so it works slightly differently. You can read more here: https://kb.workfusion.com/display/RPAe/RPA+Express+2.3.0

As for the 2nd question, do you get any error when you run your script?

No i dont get any errors. after clicking on certain element new window appears now i want to switch to new window but that new window does not appear through BOT in 2.3.0 whereas in previous everything used to run properly.

When i run application manually window appears.
Also i tried recording script using RPA Recorder everything works fine new window also appears.

“There is no Tray Menu in version 2.3, so it works slightly differently.” - I don’t know what it means. also why my application becomes background process(visible in task manager under background process) when i run the first time and works fine the second time after i do end task .

Doe this mean that this issue has been solved now, and the window appears?

I don’t understand what application you are talking about. Does RPA Express run as a background process? Or is it some application that you open with RPA Express?

Let me tell you again.

Using RPA Express i am accessing desktop application.
Lets say Application A.

First screen of A is Login screen. After login new screen appears.
On that screen when i click on some element another main screen appears on which i have to do my main process. But this third screen i am not able to open using the code that i had written using 2.2 RPAExpress. in RPAExpress 2.3 code runs till second screen only and bot clicks also on that element which triggers process to open next screen but it never does.

In RPAExpress 2.3 i recorded above procedure using RPARecorder and it worked but with the previous code it is still not working.

Another Issue - In RPAExpress 2.3 when i run the bot for the first time the desktop application which my bot is accessing opens up and than disappears and shows in Background Processes. After that i End that task from Task Manager and run the bot again now second time my bot does not convert that application as Background Process and it works fine. So this converting of Desktop application into background process is something which is unexpected and happening on its own. and may be That third screen is also getting converted in to Background process thats why i am not able to see it on screeen.

Thank you for clarification @nitinrathodHSy. We haven’t had such issues before.
What application is that? Can we download it to test and try to replicate your issue?

No actually its client side application i cant really share the application. Anyway Thanks. If i understood the issue i will post it here. For now i will uninstall 2.3 and will work on 2.2.

2 Likes