Drag and drop is not recorded with browser

web-automation
drag-and-drop

#1

I am trying to record the drag of feature of a website and it is failing or not recorded.
drag and drop


#2

HI @2015ht13160mZd

Please provide more details: does the recording start but in the end there are no steps added to the script? Or does it fail to execute when you play the recording? Could you share the recording here.

Alesia


#3

@2015ht13160mZd Could you please provide more details as requested above?
Thanks a lot.


#4

Can you share a document or link how to record a web application and best practices for it. In the meantime


#5

@2015ht13160mZd

You can find the information on how to use the recorder here: https://kb.workfusion.com/display/RPAe/How+to+Use+RPA+Recorder
Please note that the recorder is image-based, so sometimes you need to edit the recording and capture better images in order to play it back.

We are planning to add object-based recording to RPA Express in Q2 2018, which will make the recording much more precise.

Alesia


#6

But, It will record only gui apps
Not the web based one…when I tried to do, it got stuck at the browser launch itself.


#7

@2015ht13160mZd
For web, we are planning to improve the functionality too, by providing more options to work with xpaths, but it will not be available in the nearest releases.
Have you tried using the Mouse drag action? Does it result in errors, too?


#8

Yeah the record itself is failing…I will share the recording and also the screen recording as a video. By tomorrow IST.