Error executing OpenURLAction


#1

Hello, I am trying to run World_Markets example provided with Welcome package. It gives me an error in the first step. I would really appreciate if someone could walk me through a solution.

Here is a screenshot:

Here are details:
Error executing OpenURLAction
com.workfusion.studio.rpa.recorder.model.playback.PlaybackException: Error executing TemplateAction[templateName=OpenURLAction.ftl,id=1,name=Optional[OpenURLAction],parent=-1,nextSibling=2,arguments=ActionArguments[delay=[0],xsi:type=[recorder:OpenURLAction, recorder:OpenURLAction],waitTimeout=[10000],pollingInterval=[300],active=[true],comment=[This demo creates excel sheet with google world markets, performs some excel data formatting (based on default Excel menu layout) and saves it to %temp%GoogleFinanceMarkets.xlsx file.
Change file_name variable to use other file name.

Before running this demo please ensure that all mozilla firefox and excel windows are closed and also there is no Save As or Confirm Save As dialogs.

There can be issues on very small screen resolutions: titles “World Markets” and “Currencies” should be visible on the screen at the same time. Sometimes it may be needed to move player popup from the right to the left side of the screen to achieve this.],actionDetails=[(https://www.google.com/finance)],url=[https://www.google.com/finance],openUrlType=[FROM_URL],awaitTimeout=[5000]]]
at com.workfusion.studio.rpa.recorder.model.playback.flow.StandardControlFlow.execute(StandardControlFlow.java:54)
at com.workfusion.studio.rpa.recorder.model.playback.action.template.TemplateAction.execute(TemplateAction.java:27)
at com.workfusion.studio.rpa.recorder.model.playback.action.template.TemplateAction.execute(TemplateAction.java:14)
at com.workfusion.studio.rpa.recorder.model.playback.player.ActionPlayer.next(ActionPlayer.java:51)
at com.workfusion.studio.rpa.recorder.player.PlaybackLogic.playNextAction(PlaybackLogic.java:147)
at com.workfusion.studio.rpa.recorder.player.PlaybackLogic.run(PlaybackLogic.java:108)
at java.lang.Thread.run(Thread.java:745)
Caused by: groovy.lang.MissingMethodException: No signature of method: Script2.Change() is applicable for argument types: (java.lang.String) values: [GoogleFinanceMarkets.xlsx]
Possible solutions: any(), any(groovy.lang.Closure)
at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.unwrap(ScriptBytecodeAdapter.java:58)
at org.codehaus.groovy.runtime.callsite.PogoMetaClassSite.callCurrent(PogoMetaClassSite.java:81)
at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCallCurrent(CallSiteArray.java:52)
at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callCurrent(AbstractCallSite.java:154)
at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callCurrent(AbstractCallSite.java:166)
at Script2.run(Script2.groovy:2)
at com.workfusion.studio.rpa.recorder.model.playback.shell.GroovyShellWrapper.executeScript(GroovyShellWrapper.java:34)
at com.workfusion.studio.rpa.recorder.model.playback.player.PlaybackContext.executeScript(PlaybackContext.java:65)
at com.workfusion.studio.rpa.recorder.model.playback.action.template.TemplateAction.executeBehavior(TemplateAction.java:34)
at com.workfusion.studio.rpa.recorder.model.playback.flow.StandardControlFlow.execute(StandardControlFlow.java:46)
at com.workfusion.studio.rpa.recorder.model.playback.action.template.TemplateAction.execute(TemplateAction.java:27)
at com.workfusion.studio.rpa.recorder.model.playback.action.template.TemplateAction.execute(TemplateAction.java:14)
at com.workfusion.studio.rpa.recorder.model.playback.player.ActionPlayer.next(ActionPlayer.java:51)
at com.workfusion.studio.rpa.recorder.player.PlaybackLogic.playNextAction(PlaybackLogic.java:147)
at com.workfusion.studio.rpa.recorder.player.PlaybackLogic.run(PlaybackLogic.java:108)
at java.lang.Thread.run(Thread.java:745)


#2

Hi @vladimir.shoshon

Can you please confirm that you tried to re-install the application? We also would like to know your PC and OS specifications.

In case of any questions, please let us know!
Ivan Kavaleu


#3

Hello Ivan,

I haven’t tried to reinstall the application. My OS is Win10. Dell Latitude E7450. The “Open Website” command started to work (miraculously). I had a very similar issue yesterday with “Enter Keystrokes” command.

Thanks,

Vladimir


#4

I had the same issue right now.
I try again later on, maybee it has fixed itself then.
I can load the webpage manually.
It has worked before, and I use the latest firefox update from like 15 november 2018.


#5

Hi Michael, if the issue still exists when you try it next time, could you post the error text here?
Thank you.


#6

Hi Ashapkina, it remains an error for me.
I do run an old PC at my work like Windows 2010, but I think I have the latest Firefox.

I do get some strange things like:

“The default workspace C:/User/… workfusion-workspace” is in use or cannot be created. Please choose a different one."


#7

@michael_larsso can you copy and share the whole error text?

Thank you


#8

it is possible that Firefox driver used in version 2.0.5 is too old for the new Firefox. Try updating it as described in the Troubleshooting guide
https://kb.workfusion.com/display/RPAe/Troubleshooting#expand-ErrorexecutingWebElementAction

Let me know if it doesn’t help.


#9

Hi @michael_larsso please respond in this thread, not to email forum@workfusion.com.


#10

I fixed the error, I increased the Wait from 90 ms to 10.000 ms and now it works fine, thanks for the support.