Error executing TemplateAction in Control Tower


#1

Hello,

the two Scripts RPA Scripts.zip (72.7 KB) work flawlessly in the RPA Recorder and they also work without error when I run them separately in the Control Tower. But as soon as I run them chained, I receive an error rpa-node0-2017-11-08.0.zip (672.5 KB). Can you please have a look ? Thanks in advance !

Best regards


#2

The exact Control Tower error I receive when I first execute the “MUTZUEUR” script and thereafter (chained) the “MUTZUEUR KBL” script is:

Caused by: org.webharvest.exception.PluginException: com.workfusion.studio.rpa.recorder.model.playback.PlaybackException: Error executing TemplateAction[templateName=ExcelSetRangeAction.ftl,id=15,name=Optional[ExcelSetRangeAction],parent=14,arguments=ActionArguments[delay=[500],timeoutMs=[10000],xsi:type=[recorder:ExcelSetRangeAction, recorder:ExcelSetRangeAction],pollingInterval=[300],sourceVariable=[kbl_mismatch],active=[true],OpenSpreadsheetAction_filePath=[C:\Daten\KBL mismatch_MUTZUEUR.xlsx],awaitTimeout=[5000]]]

But I don´t get why the ExcelSetRange action doesn´t work in this scenario, it works perfectly in the RPA recorder and in the Control Tower when I run the “MUTZUEUR KBL” script separately (not chained). Thanks !

regards


#3

Verify that all the variable names from the 1st step match variable names from the 2nd (if the 2nd step uses some data obtained previously).

Also please check that your script saves your excel file (or not saves if it is needed), and check the Active cell - it might be changed after the 1st script execution.