Error on opening Url action

Hi ,

I was not able to launch IE window using Open URL activity. Please find the error details below.

Error executing OpenURLAction
com.workfusion.studio.rpa.recorder.playback.PlaybackException: Error executing TemplateAction[templateName=OpenURLAction.ftl,id=1,name=Optional[OpenURLAction],parent=-1,nextSibling=2,arguments=ActionArguments[delay=[50],timeoutMs=[10000],xsi:type=[recorder:OpenURLAction, recorder:OpenURLAction],pollingInterval=[300],waitTimeout=[1500],active=[true],type=[IE],url=[http://XXXXXXX/Pages/default.aspx],awaitTimeout=[5000]]]
at com.workfusion.studio.rpa.recorder.playback.flow.StandardControlFlow.execute(StandardControlFlow.java:54)
at com.workfusion.studio.rpa.recorder.playback.action.template.TemplateAction.execute(TemplateAction.java:28)
at com.workfusion.studio.rpa.recorder.playback.action.template.TemplateAction.execute(TemplateAction.java:15)
at com.workfusion.studio.rpa.recorder.playback.player.ActionPlayer.next(ActionPlayer.java:81)
at com.workfusion.studio.rpa.recorder.player.PlaybackLogic.playNextAction(PlaybackLogic.java:154)
at com.workfusion.studio.rpa.recorder.player.PlaybackLogic.run(PlaybackLogic.java:112)
at java.lang.Thread.run(Thread.java:745)
Caused by: org.openqa.selenium.WebDriverException: Failed to navigate to http://XXXXXXxxxxx.default.aspx. This usually means that a call to the COM method IWebBrowser2::Navigate2() failed.
Build info: version: ‘9.3.1.0’, revision: ‘ef4b445edf’, time: ‘2019-05-29T11:53:16.301Z’
System info: host: ‘XXXX’, ip: ‘XXXXXX’, os.name: ‘Windows 10’, os.arch: ‘amd64’, os.version: ‘10.0’, java.version: ‘1.8.0_121’
Driver info: org.openqa.selenium.remote.RemoteWebDriver
Capabilities [{proxy=Proxy(), acceptInsecureCerts=false, browserVersion=11, se:ieOptions={nativeEvents=true, browserAttachTimeout=0, ie.ensureCleanSession=false, elementScrollBehavior=0, enablePersistentHover=false, ie.browserCommandLineSwitches=, ie.forceCreateProcessApi=false, requireWindowFocus=true, initialBrowserUrl=http://localhost:22522/, ignoreZoomSetting=false, ie.fileUploadDialogTimeout=3000, ignoreProtectedModeSettings=false}, timeouts={implicit=0, pageLoad=300000, script=30000}, browserName=internet explorer, pageLoadStrategy=normal, javascriptEnabled=true, platformName=XP, setWindowRect=true, platform=XP}]
Session ID: 4b552df9-023d-41b2-8df0-11a76f9a9d6b
Command duration or timeout: 0 milliseconds
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
at org.openqa.selenium.remote.ErrorHandler.createThrowable(ErrorHandler.java:216)
at org.openqa.selenium.remote.ErrorHandler.throwIfResponseFailed(ErrorHandler.java:168)
at org.openqa.selenium.remote.http.JsonHttpResponseCodec.reconstructValue

Hi Team,

Any of you have encountered this issue with open URL activity?.

@jewel81, the only issue I recall with opening IE is sometimes when I use IE outside of WorkFusion, I’ll zoom in or out, and WorkFusion doesn’t seem to like that…so make sure the zoom in IE is at 100% before running the bot…but I feel like I received a more descriptive error message when that happened, so that may not be your issue

Hi Ryule,

Initially i have encountered the zoom issue and set the zoom option to 100%.I couldn’t find edge under my browser options and i am using version 2.3.1.Can we automate applications using edge?

Thanks

I don’t believe so, at least not through Web Actions…you could probably open it manually and navigate through it using Window controls, images, button presses, etc…

Thanks Ryule.

As suggested, will try using windows control. How about IE?

As much as possible, I try to use Keystrokes, but it’s tough to get away from using Images. I have one use case that I’d like to look more into using Window control with IE, I just haven’t gotten to it yet.

As with any Web commands, I recommend starting them like this:
image

And put all of your Web commands within the “Switch to Browser” function