Error paying recording in RPA Express

rpa
rpaexpress
rparecorder

#1

Hi All,

I am getting below error whily playing recording:

Unable to connect with Robot
org.openqa.selenium.remote.UnreachableBrowserException: Could not start a new session. Possible causes are invalid address of the remote server or browser start-up failure.

    Build info: version: '8.3.5-SNAPSHOT', revision: 'unknown',
    time: '2017-06-14 10:10:21'

    System info: host: '5CG430189S', ip: '127.0.0.1', os.name:
    'Windows 7', os.arch: 'amd64', os.version: '6.1', java.version: '1.8.0_121'

Driver info: driver.version: RemoteWebDriver
at org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:633)
at org.openqa.selenium.remote.RemoteWebDriver.startSession(RemoteWebDriver.java:212) 
at org.openqa.selenium.remote.RemoteWebDriver.<init>(RemoteWebDriver.java:94) 
at org.openqa.selenium.remote.RemoteWebDriver.<init>(RemoteWebDriver.java:121)
at com.freedomoss.crowdcontrol.webharvest.selenium.wrapper.RemoteDriverWrapper.<init>(RemoteDriverWrapper.java:44)
at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.initDriver(ActionFlowPlayer.java:166)
at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.play(ActionFlowPlayer.java:113)
at com.workfusion.studio.rpa.recorder.views.PlayerControlWindow.lambda$8(PlayerControlWindow.java:168)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)

Can anyone please help.


#2

Try to restart “All Component” from the system tray and if that doesn’t work exit everything and try reopen RPA recorder. I faced a similar type of issue and it was resolved through the aforementioned steps.

Try to create a new recording and check if you are getting the same error on that too.


#3

Hi,

Now getting another error:

Unable to connect with Robot
org.openqa.selenium.WebDriverException: Can’t get object clsid from progid
Command duration or timeout: 308 milliseconds
Build info: version: ‘8.3.5-SNAPSHOT’, revision: ‘unknown’, time: '2017-06-14 10:10:21’
System info: host: ‘5CG430189S’, ip: ‘100.96.80.253’, os.name: ‘Windows 7’, os.arch: ‘amd64’, os.version: ‘6.1’, java.version: '1.8.0_121’
Driver info: com.freedomoss.crowdcontrol.webharvest.selenium.wrapper.RemoteDriverWrapper
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)


#4

Check your Network Connection.


#5

Thanks a lot for reply

I am connected with office WIFI, and workfusion is working fine on my friends machine but not on machine and we both are on same network.


#6

Even I am working in the same scenario and faced the same issue.
Open the tool RPA Express Go to - Windows -> Preferences -> General -> Network Connections and match the connection/proxy/port/Active Provider with the machine on which RPA is working.