Error setting value for xpath

issues
xpath
chromedriver

#1

Hello,

I am trying to insert a value in the “Email” text box through the xpath and an error appears:

Below settings:

Site that I am trying to set the value:

https://pub_demo.s3.amazonaws.com/invoiceplane-2/InvoicePlaneDemo.html

Below the groovy code:

import com.workfusion.studio.rpa.recorder.api.*
import com.workfusion.studio.rpa.recorder.api.types.*
import com.workfusion.studio.rpa.recorder.api.custom.*
import com.workfusion.studio.rpa.recorder.api.internal.representation.*
enableTypeOnScreen()

timeouts().pageLoadTimeout(10000, java.util.concurrent.TimeUnit.MILLISECONDS)

openChrome(UrlOperations.ensureProtocol("https://pub_demo.s3.amazonaws.com/invoiceplane-2/InvoicePlaneDemo.html"))
sleep(3000)


  $(byXpath("${xpath_user}")).setValue(String.valueOf(email))

sleep(5000)

Thanks


#2

Mauricio,
you need to update Chromedriver.


Problem with Firefox in RPAx 1.3.0
#3

Its workeds !!!

Thank you very much


#4

Issue Chrome.zip (10.7 KB)

Hi Team,

I am trying set company id- through XPath in the Chrome and getting error as - " call function result missing ‘value’ ". However, same code is working fine in “FireFox”. I am having this issue last 2 days. Previously, the same process was working fine with Chrome. I have reinstalled both Chrome as well as workfusion. But the issue still persist.

Kindly check.


#5

Hi Lakshmi,

You need to update your Chrome driver. See how to do it in the post above.


#6

Thanks… It worked


#7

Added to Troubleshooting guide - https://kb.workfusion.com/display/RPAe/Troubleshooting#expand-ErrorexecutingWebElementAction