Error while installing work fusion RPA Express

issues

#1

Applying execute package: WorkFusionRPAExpress.msi, action: Install, path: C:\ProgramData\Package Cache{940B81FE-080D-4F90-9869-DFDF869F83FD}v1.1.8\resources\WorkFusionRPAExpress.msi, arguments: ’ ARPSYSTEMCOMPONENT=“1” MSIFASTINSTALL=“7” WIXBUNDLEORIGINALSOURCE=“C:\Users\sriprash\Downloads\RPAExpressInstaller\RPAExpressInstaller.exe”’
[16A0:08DC][2018-01-11T17:43:35]e000: Error 0x80070643: Failed to install MSI package.
[16A0:08DC][2018-01-11T17:43:35]e000: Error 0x80070643: Failed to execute MSI package.
[2B6C:2678][2018-01-11T17:43:35]e000: Error 0x80070643: Failed to configure per-machine MSI package.
[2B6C:2678][2018-01-11T17:43:35]i319: Applied execute package: WorkFusionRPAExpress.msi, result: 0x80070643, restart: None
[2B6C:2678][2018-01-11T17:43:35]e000: Error 0x80070643: Failed to execute MSI package.
[16A0:08DC][2018-01-11T17:43:35]i301: Applying rollback package: WorkFusionRPAExpress.msi, action: Uninstall, path: (null), arguments: ’ ARPSYSTEMCOMPONENT=“1” MSIFASTINSTALL=“7” WIXBUNDLEORIGINALSOURCE=“C:\Users\sriprash\Downloads\RPAExpressInstaller\RPAExpressInstaller.exe”’
[2B6C:2678][2018-01-11T17:47:08]i319: Applied rollback package: WorkFusionRPAExpress.msi, result: 0x0, restart: None
[16A0:08DC][2018-01-11T17:47:08]i329: Removed package dependency provider: {940B81FE-080D-4F90-9869-DFDF869F83FD}, package: WorkFusionRPAExpress.msi
[16A0:08DC][2018-01-11T17:47:08]i351: Removing cached package: WorkFusionRPAExpress.msi, from path: C:\ProgramData\Package Cache{940B81FE-080D-4F90-9869-DFDF869F83FD}v1.1.8
[16A0:08DC][2018-01-11T17:47:08]i372: Session end, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall{58b88b7f-d8bc-4cc4-b859-fc32cebecb3c}, resume: None, restart: None, disable resume: No
[16A0:08DC][2018-01-11T17:47:08]i330: Removed bundle dependency provider: {58b88b7f-d8bc-4cc4-b859-fc32cebecb3c}
[16A0:08DC][2018-01-11T17:47:08]i352: Removing cached bundle: {58b88b7f-d8bc-4cc4-b859-fc32cebecb3c}, from path: C:\ProgramData\Package Cache{58b88b7f-d8bc-4cc4-b859-fc32cebecb3c}
[16A0:08DC][2018-01-11T17:47:08]i371: Updating session, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall{58b88b7f-d8bc-4cc4-b859-fc32cebecb3c}, resume: None, restart initiated: No, disable resume: No
[2B6C:2678][2018-01-11T17:47:09]i399: Apply complete, result: 0x80070643, restart: None, ba requested restart: No


#2

@prashant_sriFs
Hi Prashant, please follow the steps in the Troubleshooting guide: https://kb.workfusion.com/display/RPAe/Troubleshooting#expand-Errorcode0x80070643

Alesia


#3

I have been using workfusion for past 2 weeks but toaday i have to uninstalled it as it could able to start showing some error. After it can not able to install showing error :- setup wizard ended prematurely beacuse of an error.
os :- windows 8.1 pro
RAM :- 16 GB
Space : 1TB
System Type :- 64 bitWorkFusion_RPA_Express_20180111230828.log (21.1 KB)


#4

Got the same issue upon installation and keeps on rolling back.
Was able to solve by doing the following:

  • Installing Windows update KB3177467 (Not sure if it has bearing, but I keep on searching to solve for one issue I got for creating restore point)
  • Disabling Anti-virus
  • Enabling windows firewall (I just saw that RPA express is writing something during installation, and last time it was disabled)

Hope this helps.


#5

Is their any other solution as i can not disable Ant-Virus due to company policy


#6

@prashant_sriFs

Hi Prashant, please send us the MSI log - large file (60 to 200 MB) located in C:\Users*user*\AppData\Local\Temp folder.

Thank you,
Alesia


#7

Hi Alesia, In \temp Folder their is no MSI log.


#8

@prashant_sriFs
Hi Prashant, have you tried installing the latest RPAx 1.1.9?
Do you still have this issue with this version?


#9

I have formated my laptop and tried again to install and i don’t know why but now it get installed.


#10

Hello,
I am getting the same error " Error 0x80070643: Failed to install MSI package." Can you please guide me what should I do. I can’t format my laptop because too many things are running on it.Please suggest any other solution .

build=431
version_number=1.1.9
version=Sunbird
timestamp=Fri 01/12/2018 8:15:19.10

Regards
Ibrar


#11

@ibraars
Hi Ibrar,
Have you tried the steps described in the Troubleshooting guide?
https://kb.workfusion.com/display/RPAe/Troubleshooting#expand-Errorcode0x80070643

Alesia


#12

@ashapkina
Hello ashapkina,
Thank you for your support. The issue has been resolved by disabling the antivirus.

Ibrar


#13

@ibraars Glad it was helpful.