Execution error - MalformedURLException

After upgrading to Lumen from the prior version, all previous working recordings are now generating the following when played :

java.net.MalformedURLException: no protocol:
com.workfusion.studio.rpa.recorder.player.driver.DriverInitializationException: java.net.MalformedURLException: no protocol:
at com.workfusion.studio.rpa.recorder.player.driver.RpaUniversalDriver.getSeleniumServerUrl(RpaUniversalDriver.java:137)
at com.workfusion.studio.rpa.recorder.player.driver.RpaUniversalDriver.initialize(RpaUniversalDriver.java:64)
at com.workfusion.studio.rpa.recorder.player.PlaybackLogic.run(PlaybackLogic.java:76)
at java.lang.Thread.run(Thread.java:745)
Caused by: java.net.MalformedURLException: no protocol:

1 Like

After uninstalling old version and installing the new version 2.0.
Then I started the “Play recording”. An error occurred. It wont start

java.net.MalformedURLException: no protocol:
com.workfusion.studio.rpa.recorder.player.driver.DriverInitializationException: java.net.MalformedURLException: no protocol:
at com.workfusion.studio.rpa.recorder.player.driver.RpaUniversalDriver.getSeleniumServerUrl(RpaUniversalDriver.java:137)
at com.workfusion.studio.rpa.recorder.player.driver.RpaUniversalDriver.initialize(RpaUniversalDriver.java:64)
at com.workfusion.studio.rpa.recorder.player.PlaybackLogic.run(PlaybackLogic.java:76)
at java.lang.Thread.run(Thread.java:745)
Caused by: java.net.MalformedURLException: no protocol:

@soa_kmd_dkFAxJ @mark_watson
Go to Server profile - Manage profiles at the bottom right corner of RPA Express
image

and check the Bot Relay URL. It should be http://localhost:15444/wd/hub

Correct it if it is empty or incomplete.

image

7 Likes

Hello and thanks. No it didn’t have an bot relay. Just another question how do I use the remote desktop and what for?

Can you play the recordings now?

Yes and many thanks -)

1 Like

Each remote desktop is for each additional bot you created during the installation.
You can play several business processes from the Control Tower simultaneously, and they will be executed on different remove desktops at the same time.

Ok last question. I have a remote desktop ip: 127.0.0.2.
when i publish to control tower. And run it, then i see the actions on my pc and not my remote desktop.
Confusion!!!

All your bots have the same ip, and the process is executed on the first available bot, in this case your local pc. If you need to make sure that the process is always executed on a remote desktop, you can stop the bot on your local machine in Platform monitor.

image

I have upgraded the RPA express version 2.0.

I am trying to click on some item through mouse click “windows_control”.
Below error shown-
error_windows_control

Please help!!
Thanks

@vikas_rawat1 you can find the solution above.

1 Like

Thanks.

It worked for me.

:slight_smile:

2 Likes

I Am trying to open a URL using open website action but getting below mentioned error. It was working fine but suddenly started facing this issue.

java.net.MalformedURLException: no protocol:

Hi Naveen, please see the solution in the thread above.

@ashapkina What url should I provide in Bot Relay.

http://localhost:15444/wd/hub

1 Like

thanks it’s working now.

1 Like

Thank you. The Bot Relay URL was blank. The player is now working.

1 Like

Thank you for update Mark. Was only Bot Relay settings blank? or all of them?

Reason
java.net.MalformedURL.Exceptions: no protocol

Getting an error as such.could you please help me how to fix this.