Express 1.1.8 also freezes

Hi,

I have automated a quite large process, that is based on a loop. When the process have been through the loop a couple of times, the recording player always stalls / freezes (not always at the same step) - even though there is NO difference between each loop performed. I get no error-message, i just have to close everything down and start from scratch. This is not so good, when the loop is supposed to loop 250 times.

Is there somewhere in a logfile or something, where I can see where the problem is located?

The process is based on a private website, so i can not really share the source file :expressionless:

I have a i7-6820HQ and 16 gb. ram.

Best regards :grinning:

The problem is also present in 1.1.7. Another problem is, that when I have used a fresh installation for a while, it starts to hang (or even freeze) when I open Workfusion RPA Express.

There is about 872 actions in the RPAE - is this just too much for RPA Express? I have used incredibly much time on the project, so it is quite devastating to find out, that RPA Express is just freezing, when I try to use the automation for real in a no-test context with more that three loop-iterations.

@Jens_Jespersen5,

can you please tell us:

  • how many actions are there before your loop?
  • how many actions are there inside your loop?
  • can you create a sample recording with some public website and common apps (notepad, excel) which has similar structure and reproduces the issue?

19 before the loop - 851 inside the loop. 851 sounds as many, but only about the half is used in each iteration (it varies which), but when i’m testing it is always with fx. 10 times the same inputdata (exactly the same iterations).

I will try, but it might not be that easy, but perhaps if i copy/paste a lot. I will try tomorrow :slight_smile:

Not quite the same structure, but it does the job - at my computer at least. recording-123.zip (17.4 KB) the recorderplayer / RPA Express stalled / freezed at my computer at 1. loop iteration - action 256.

1 Like

@Jens_Jespersen5
thanks for the recording. We will investigate the case and let you know the results.

1 Like

Any luck? :slight_smile:

@Jens_Jespersen5

We could not reproduce it so far with your sample recording.
The following suggestion:

Please, share the results of your investigation.

Okay. I don’t really know what to look for - i am not in need of PC Resources, and the windows logs does not seem to contain anything interesting. The problem is still present - the fresh installation I installed today - with fresh workspace (which worked perfectly fine the first 20 minutes), is not even to get past the splash screen without freezing anymore. Time for a fresh installation again.

The sounds a bit like my problems: Problem with the Bot of the RPA express

The sample recording was not working for me earlier today either - perhaps it only work when the installation is “ready for reinstallation”.

Try this… delete all the log files in this folder …\workfusion-workspace\ .metadata

It worked for me when my bot stopped without giving me any error.

Make a backup before that…

1 Like

My post was closed and… I wanted to post what I did in order to solve my problem … XD

@azinchuk Can you unlock my post?

Thanks.

Hurray it worked! :+1::hugs::star_struck:

But I guess that I soon will have to delete it again? Can we make it empty it self?

1 Like

I did a script in powershell that deletes every file that has the word “log”, and my bot launches that script every 3 days …

With my 8xx action bot, these logfiles get too large very fast. I need to delete dem “on the fly”. Any suggestions for a solution anyone?

A build-in solution would be prefered of couce.

I have 10 processes that runs every 3 mins. Each procesees have 70-124 acctions (with loops each process can reach 400).

I have problems when I run my scripts several times from the RPA recorder, but when I run it from the control tower I don’t have that problems (but i have to have the \workfusion-workspace\ .metadata folder empty).

:smiley:

With loops mine is about 100.000 actions - now I made the log-files write-protected :thinking:. Will test with it tomorrow.

@joreian,

your topic is active

@Jens_Jespersen5, @joreian we will investigate this issue and fix it in 1.1.8

Please post the log file list and with their size at the moment when your recording freezes.

Thanks!

The write-protected logs seems to work. I will check the size asap - for now I am just getting this error instead (randomly):