Express 1.1.8 also freezes

This definitely makes a difference for me - the lower the MaxmetaspaceSize is set, the shorter is the amout of time RPAE will last, but it does not solve the problem.

I had already made this change. Is there a max setting for this or the others? If I can move it up to 2048, 4096 or more…What is the limitation? Currently processes 200+ records but max files require 3,000 or more.

@jdoering - are you sure you have edited the recorder.ini file? At first I’ve advised to edit config.ini file, which was wrong.

And yes, you can set 2048, 4096 - but it depends on your PC available resources.

Azinchuk - what happens for you, if you set MaxmetaspaceSize to fx. 128m and run a process until the limit is reached?

@azinchuk Is there any MaxMetaspaceSize in the Control Tower???

Thanks.

Again: MaxmetaspaceSize is not the solution.

I made the correction to the recorder ini file (updated to 2048) and have write protected the log files. However, it still hangs during processing. Have you made any progress on a long-term fix? Need to be able to handle thousands, not hundreds of records.

Does 1.1.8 correct this issue?

@jdoering,

we are continuing our investigation.

BTW, if you plan to execute thousands of records, the SPA product with its multi-bot configuration is a better solution.

1.1.8 does not seem to contain the solution either.

It sounds great that you are continuing the investigation. I really don’t think that the task my robot is handling is rocket science, so I think you must expect more users to run into these problems, as their robots gets more advanced / more demanding (and closer to the finish line!). The problem is also, that it takes a lot of development time / work hours, before you will meet these problems.

I don’t think that a multi-bot configuration should be nessasary for my needs for now. My proces is made of a few loops - and is making the first 10 loops perfectly fine, but is then getting clogged up and stalls. The drains just seems to need a little cleaning during the run to prevent this… :slightly_smiling_face:

3 Likes

Yep. I face the same problem. My problem is even more worse that even after restarts it hangs soon. Is Bot manager holding things in memory of previous runs etc?

Lets give 1.1.9 a try :slight_smile:

1 Like

There are some performance improvements in 1.1.9, mainly for Loops and Text actions.
But we are still continuing to work on improving memory usage to solve or at least minimize the issue described above. Hopefully, we will be able able to implement it in the next release.

@Jens_Jespersen5 @JThangaswamy @joreian @jdoering @gerhardus_meyer

Hi all, please check out RPA Express 1.2.0, it contains performance improvements for large recordings with loops.
It would be great if you could five us your feedback and let us know if it improved your scripts execution, so we know what to further focus on.

Thanks a lot!

1 Like

will test and let you know

1 Like

I ran a test with an input file with 2000 records using Version 1.2.0 RPA Recorder so I could watch it. It made it to 890 this time after 5 hours of processing. However, it died with the following error: “Caused by: java.lang.OutOfMemoryError: Java heap space” - See attached for details. The computer still had 40 GB of disk and log files appear to be ok… Thoughts? I will rerun today and verify results.

AR-AllocateV3.zip (687.2 KB)

2018-RPA-DumpOutput.txt (4.5 KB)

tomcat folder logs.zip (8.0 MB)

On the 2nd run… I watched as it gets the error that Eclipse is out of memory. Java Heap space error. The Eclipse ReadMe says to increase memory? Is this the MaxMetaspaceSize setting? or the Xmx setting in recorder.ini?

@jdoering I created a ticket for the support team, they’ll investigate.
MaxMetaspaceSize setting will not help in this case.
Try increasing the xmx settings in recorder.ini. Please let us know if it helps.

@Jens_Jespersen5 @jdoering @joreian @JThangaswamy @gerhardus_meyer @athos.whittington

We have added data caching to the recorder that will make execution in loops faster. The version with this fix will be release at the beginning of September.

If you want to use it now, you can add data caching manually:

  • close WorkFusion Studio
  • open C:\RPAExpress\Studio\configuration\config.ini file
  • add recorder.player.use.cache=true and save the file
  • reopen WorkFusion Studio

Let us know if it helps the execution

1 Like

The new release 2.1.0 contains performance improvements for action in loops.
Let us know whether this helps solve this issue.