Express 1.1.8 also freezes

Ok.

I don’t normally use the control tower (does really not make a difference in regard to stalling) - my tomcat logfolder is only 62,2 kb. :slightly_smiling_face:

Did you try to export your script to the control tower (with empty log files)???

It worked for me… my bot works better and faster in the control tower.

Yes, this is not the solution, unfortunately :slight_smile:

@Jens_Jespersen5, @joreian, @jdoering

Please try to do the following:

  1. Close Recorder

  2. Open the C:\RPAExpress\Recorder\recorder.ini file using your text editor

  3. Append the following string:
    -XX:MaxMetaspaceSize=1024m

  4. Save the file and start the Recorder.

And please describe how your system behaves when Recorder is stuck - is Windows also performing slowly or as usual?

For me, the job is running fine and at the same pace until it gets to that “time”. Then it just stops processing. If I am in the Recorder I can see the step just stop. When I click the red stop button, I get a blue circle spinning cursor that keeps going on and on. I will append the string.

And can you click in other other Windows apps? (browser, etc) Do they respond to clicks or not?

The problem described by jdoering is still present here with the string “-XX:MaxMetaspaceSize=1024m” appended.

With the extension, it ran for 225 records instead of the previous 120 records or after about 4 hours (almost exactly). All the other windows remain active and I can do whatever I need to in those, however, the playback hangs on a step in the manual playback - activity just stops and the step monitor just sits on that step. When I click stop, I get the Blue spinning circle cursor, where I usually wait 10-15 minutes then have to shut down and reboot to restart everything clean.

My recording also ran longer but it stopped, I increased the value even more and it ran for a bit longer. Why would the file keep on increasing with each run? the javaw.exe in my system manager increases to over 6GB

BTW i have to run through 200 000 records but the loops and checks are minimal and even the file size is about 18 MB…

When the process finally finishes/ends I get the following as well.

@gerhardus_meyer, @Jens_Jespersen5, @jdoering, @joreian

Sorry, told you a wrong file. You need to do the following:

  1. Close Recorder

  2. Open the C:\RPAExpress\Recorder\recorder.ini file using your text editor (preferable Notepad++ or Sublime)

  3. Append the following string on a new line:
    -XX:MaxMetaspaceSize=1024m

  4. Save the file and start the Recorder.

This definitely makes a difference for me - the lower the MaxmetaspaceSize is set, the shorter is the amout of time RPAE will last, but it does not solve the problem.

I had already made this change. Is there a max setting for this or the others? If I can move it up to 2048, 4096 or more…What is the limitation? Currently processes 200+ records but max files require 3,000 or more.

@jdoering - are you sure you have edited the recorder.ini file? At first I’ve advised to edit config.ini file, which was wrong.

And yes, you can set 2048, 4096 - but it depends on your PC available resources.

Azinchuk - what happens for you, if you set MaxmetaspaceSize to fx. 128m and run a process until the limit is reached?

@azinchuk Is there any MaxMetaspaceSize in the Control Tower???

Thanks.

Again: MaxmetaspaceSize is not the solution.

I made the correction to the recorder ini file (updated to 2048) and have write protected the log files. However, it still hangs during processing. Have you made any progress on a long-term fix? Need to be able to handle thousands, not hundreds of records.

Does 1.1.8 correct this issue?

@jdoering,

we are continuing our investigation.

BTW, if you plan to execute thousands of records, the SPA product with its multi-bot configuration is a better solution.