Failed loading FREngine: ABBYY Licensing Service is unavailable: The RPC server is unavailable

Trying for a simple OCR feature testing. The OCR Engine is failing with the below error.
Using the latest WF version 1.1.5
Failed loading FREngine: ABBYY Licensing Service is unavailable: The RPC server is unavailable.
Attaching the logs and the screen shot of the flow.
How to
ocr-task.log (91.3 KB)
OCR

Hello Mahesh!

Could you please provide us with the screenshot that shows the tray menu area, so we can see if the OCR service is running? And also, could you please clarify where you got this error?
Besides, you can try steps from this article: https://kb.workfusion.com/display/RPAe/Troubleshooting#expand-FailedtoexecuteOCRAction
Please inform us if it was helpful or not.
Thank you!

Best regards,
Darya Novikova
WorkFusion Service Desk

We have verified the link still getting same error.
Yes the OCR service is started up and running

Can you help in getting the OCR issue resolved i have to show a demo for the OCR feature is working fine , it has been pending for long. Would be of great help if you can help me getting this resolved.
Thanks & Regards,
Mahesh

Dear @Mahesh_Ramaswamy_CT1

Sorry for the late reply,
Can you please confirm that you visit this article: https://kb.workfusion.com/display/RPAe/Troubleshooting#expand-RPAExpressComponentlogs and tried to follow the steps?

Thanks,
Ivan Kavaleu
WorkFusion Service Desk

Ivan have verified all the components are up and running in the platform monitor.
The other automations are working fine using WF only ocr is not giving output it is giving an

Tried running the sample ocr BP program coming along with Account payable.
Please find the error message.

Does Abby Licensing is enabled with the default installation of the WF RPA Express or should i run any commands to activate it.
When i click the Abby License Manager i am getting the same error

as i see in the logs.

ivan i have a demo tomorrow, can you help me to sort out the ocr issue.

Hi, @Mahesh_Ramaswamy_CT1
Please, send logs from INSTALL_DIR\OCR\logs\rest
there should be 2 files, please, attach them here

logs.zip (39.8 KB)
Please find the logs taken from the OCR\logs\rest

@Mahesh_Ramaswamy_CT1
Can you also take a screenshot of content from
INSTALL_DIR\OCR\Licenses

Please, open recorder, and click on generate groovy
and paste code here
2017-09-27_2-32-11

nableTypeOnScreen();

openAndFocus("C:\\Notepad++\\notepad++.exe", 5000, 300);

sleep(4000);
org.openqa.selenium.Rectangle i0 = $(byImage("1506459384064-anchor.apng")).getRect();
testocr = Ocr.proccessImage(sysOcrApiUrl.toString(), i0.x + 169, i0.y + 20, 174, 24);

    if (testocr instanceof com.workfusion.studio.rpa.recorder.api.groovy.RecorderList) {
        setClipboardText(com.workfusion.studio.rpa.recorder.utils.DelimitedConverterUtils.listToString(testocr, "", ""));

    } else if (testocr instanceof com.workfusion.studio.rpa.recorder.api.groovy.RecorderTable) {
        setClipboardText(com.workfusion.studio.rpa.recorder.utils.DelimitedConverterUtils.tableToString(testocr, "", "", ""));

    } else if (testocr instanceof BigDecimal) {
        setClipboardText(testocr.toPlainString());

    } else if (testocr instanceof Date) {
        setClipboardText(java.text.DateFormat.getInstance().format(testocr));

    } else {
        setClipboardText(String.valueOf(testocr));
    }

i have updated the groovy script code for the ocr. Can you help in resolving this issue it has been pending for long time

Hello,
sorry for long reply
please send us your licenses files from RPAExpress\OCR\Licenses and RPAExpress\OCR\FineReaderEngine\Licenses
also please try to reinstall RPAx and reproduce this issue

Best regards,
Anton

Licenses_OCR.zip (9.1 KB)
Licenses_FineReaderEngine.zip (8.5 KB)

Hi,

We have attached both the license.
Licenses_OCR.zip - Installed directory D:\RPA Express 1.1.5\OCR
Licenses_FineReaderEngine.zip - Installed directory D:\RPA Express 1.1.5\OCR\FineReaderEngine

Waiting for the quick response. Its pending for long time.

Thanks
Mahesh

@Mahesh_Ramaswamy_CT1,

You have different license files in OCR\licenses and FineReaderEngine\licenses folders.

Anyway, these licenses are not valid now, so just install the new 1.1.6 release with a renewed OCR license.

Hi,

We have installed the new version 1.1.6, now also OCR is not working as expected.
We have attached the latest file license.
Licenses_OCR.rar - Installed directory C:\RPAExpress\OCR
Licenses_FineReaderEngine.rar - Installed directory C:\RPAExpress\OCR\FineReaderEngine
Licenses_OCR.rar (8.7 KB)
Licenses_FineReaderEngine.rar (8.2 KB)

Thanks
Mahesh