Failed to convert property value of type" error prevents RPAx to start up

issues
splashscreen
launch

#1

Hi,

RPA Express - fail to start due to failed property (target.model) conversion

Detailed Error log below. Advise for further information/resolution?

APPLICATION FAILED TO START

Description:


Binding to target Config [components=[ComponentConfig [id=wf, name=Control Tower, group=wf, description=null, link=null, enabled=true, alerts=[wf.app], schedule=20], ComponentConfig [id=ws, name=WorkSpace, group=wf, description=null, link=null, enabled=true, alerts=[ws.app], schedule=20], ComponentConfig [id=ocr, name=OCR, group=ocr, description=null, link=null, enabled=true, alerts=null, schedule=60], ComponentConfig [id=rpa.hub, name=RPA Hub, group=rpa.grid, description=null, link=null, enabled=true, alerts=[rpa.hub], schedule=20], ComponentConfig [id=rpa.node, name=RPA Node, group=rpa.grid, description=null, link=null, enabled=true, alerts=[rpa.node], schedule=20], ComponentConfig [id=mysql, name=MySQL, group=db, description=null, link=null, enabled=true, alerts=[mysql], schedule=20], ComponentConfig [id=postgresql, name=PostgreSQL, group=db, description=null, link=null, enabled=true, alerts=[postgres], schedule=20]], groups=[GroupConfig [id=wf, name=Applications, collapsed=0], GroupConfig [id=rpa.grid, name=Bot Manager, collapsed=0], GroupConfig [id=ocr, name=OCR, collapsed=0], GroupConfig [id=db, name=Databases, collapsed=0]], alerts=[AlertConfig [id=ws.app, description=null, triggers=[AlertCheckConfig [metric=ws.app.status, type=MAJOR_OUTAGE, message=Web check failed, neq=0.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null], AlertCheckConfig [metric=ws.app.http.code, type=MAJOR_OUTAGE, message=WorkSpace is not responding properly, neq=200.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null]], enabled=true, dependson=null, templates=null, items=null], AlertConfig [id=wf.app, description=null, triggers=[AlertCheckConfig [metric=wf.app.status, type=MAJOR_OUTAGE, message=Web check failed, neq=0.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null], AlertCheckConfig [metric=wf.app.http.code, type=MAJOR_OUTAGE, message=WorkFusion is not responding properly, neq=200.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null]], enabled=true, dependson=null, templates=null, items=null], AlertConfig [id=rpa.hub, description=null, triggers=[AlertCheckConfig [metric=rpa.hub.status, type=MAJOR_OUTAGE, message=Web check failed, neq=0.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null], AlertCheckConfig [metric=rpa.hub.http.code, type=MAJOR_OUTAGE, message=RPA Hub is not responding properly, neq=200.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null]], enabled=true, dependson=null, templates=null, items=null], AlertConfig [id=rpa.node, description=null, triggers=[AlertCheckConfig [metric=rpa.node.status, type=MAJOR_OUTAGE, message=Web check failed, neq=0.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null], AlertCheckConfig [metric=rpa.node.http.code, type=MAJOR_OUTAGE, message=RPA Node is not responding properly, neq=200.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null]], enabled=true, dependson=null, templates=null, items=null], AlertConfig [id=mysql, description=null, triggers=[AlertCheckConfig [metric=mysql.query1.status, type=MAJOR_OUTAGE, message=Problem with mysql query, neq=0.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=3, dependson=null, interval=null]], enabled=true, dependson=null, templates=null, items=null], AlertConfig [id=postgres, description=null, triggers=[AlertCheckConfig [metric=postgres.query1.status, type=MAJOR_OUTAGE, message=Problem with postgres query, neq=0.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=3, dependson=null, interval=null]], enabled=true, dependson=null, templates=null, items=null]], checks=[CheckConfig [id=rpa.ct.disk, type=COMMAND, file=null, expression=wmic logicaldisk get size,freespace,caption, schedule=60, evaluate=[FunctionConfig [id=table.value.index, metric=, metricName=memfree, arg=0,C:,1, parameters={}, type=LONG, register=true, onFail=false], FunctionConfig [id=table.value.index, metric=, metricName=memtotal, arg=0,C:,2, parameters={}, type=LONG, register=true, onFail=false]], credentials=null, source=null, description=Get available disk space, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=rpa.ct.os, type=COMMAND, file=null, expression=wmic OS get Caption,OSArchitecture,FreePhysicalMemory,TotalVirtualMemorySize,FreeVirtualMemory,LastBootUpTime /format:list, schedule=60, evaluate=[FunctionConfig [id=properties, metric=null, metricName=null, arg=, parameters={}, type=LONG, register=true, onFail=false]], credentials=null, source=null, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=rpa.ct.computersystem, type=COMMAND, file=null, expression=wmic ComputerSystem get TotalPhysicalMemory /format:list, schedule=60, evaluate=[FunctionConfig [id=properties, metric=null, metricName=null, arg=, parameters={}, type=LONG, register=true, onFail=false]], credentials=null, source=null, description=Get total physical memory, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=rpa.ct.cpu, type=COMMAND, file=null, expression=wmic cpu get loadpercentage /format:list, schedule=60, evaluate=[FunctionConfig [id=properties, metric=null, metricName=null, arg=, parameters={}, type=LONG, register=true, onFail=false]], credentials=null, source=null, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=rpa.ct.java, type=COMMAND, file=null, expression=java -version, schedule=60, evaluate=[FunctionConfig [id=command.output, metric=, metricName=version, arg=, parameters={}, type=STRING, register=true, onFail=false]], credentials=null, source=null, description=Get java version, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=rpa.hub.slots, type=HTTP, file=null, expression=/grid/api/hub, schedule=30, evaluate=[FunctionConfig [id=http.json, metric=, metricName=waiting, arg=newSessionRequestCount, parameters={}, type=INT, register=true, onFail=false], FunctionConfig [id=http.json, metric=, metricName=free, arg=slotCounts.free, parameters={}, type=INT, register=true, onFail=false], FunctionConfig [id=http.json, metric=, metricName=max, arg=slotCounts.total, parameters={}, type=INT, register=true, onFail=false], FunctionConfig [id=expression, metric=, metricName=running, arg=%max% - %free%, parameters={}, type=INT, register=true, onFail=false]], credentials=null, source=RpaHub, description=Generate robot metrics from RPA Hub, parameters={request=GET, body={"configuration":["newSessionRequestCount","slotCounts"]}}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=rpa.hub, type=HTTP, file=null, expression=/grid/console, schedule=10, evaluate=[FunctionConfig [id=rpa.agent.items, metric=null, metricName=null, arg=nodes, parameters={}, type=LONG, register=true, onFail=false], FunctionConfig [id=tray.status.update, metric=null, metricName=null, arg=rpa, parameters={}, type=LONG, register=true, onFail=true]], credentials=null, source=RpaHub, description=Generates list of all nodes of a hub, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=rpa.node, type=HTTP, file=null, expression=/wd/hub/static/resource/hub.html, schedule=20, evaluate=null, credentials=null, source=RpaNode, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=wf.app, type=HTTP, file=null, expression=/workfusion/login, schedule=10, evaluate=[FunctionConfig [id=tray.status.update, metric=null, metricName=null, arg=workfusion, parameters={}, type=LONG, register=true, onFail=true]], credentials=null, source=WF, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=ws.app, type=HTTP, file=null, expression=/workspace/login, schedule=30, evaluate=null, credentials=null, source=WF, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=ocr.app, type=HTTP, file=null, expression=/, schedule=30, evaluate=[FunctionConfig [id=tray.status.update, metric=null, metricName=null, arg=ocr, parameters={}, type=LONG, register=true, onFail=true]], credentials=null, source=OCR, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=collector, type=JAVA, file=null, expression=null, schedule=60, evaluate=[FunctionConfig [id=action.events.log, metric=null, metricName=null, arg=, parameters={}, type=LONG, register=true, onFail=false]], credentials=null, source=null, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=mysql.query1, type=SQL, file=null, expression=select database() as db, schedule=60, evaluate=[FunctionConfig [id=sql.output, metric=, metricName=name, arg=db, parameters={}, type=STRING, register=true, onFail=false]], credentials=null, source=Mysql, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=postgres.query1, type=SQL, file=null, expression=select current_database() as db, schedule=60, evaluate=[FunctionConfig [id=sql.output, metric=, metricName=name, arg=db, parameters={}, type=STRING, register=true, onFail=false]], credentials=null, source=Postgres, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false]], datasources=[DataSourceConfiguration [id=WF, protocol=%wf_protocol%, host=%wf_hostname%, port=%wf_port%, db=null, type=HTTP, url=null, user=null, account=null], DataSourceConfiguration [id=OCR, protocol=%ocr_protocol%, host=%ocr_hostname%, port=%ocr_port%, db=null, type=HTTP, url=null, user=null, account=null], DataSourceConfiguration [id=RpaHub, protocol=%rpa_hub_protocol%, host=%rpa_hub_hostname%, port=%rpa_hub_port%, db=null, type=HTTP, url=null, user=null, account=null], DataSourceConfiguration [id=RpaNode, protocol=%rpa_hub_protocol%, host=%rpa_hub_hostname%, port=%rpa_node_port%, db=null, type=HTTP, url=null, user=null, account=null], DataSourceConfiguration [id=Mysql, protocol=null, host=null, port=null, db=null, type=MYSQL, url=jdbc:mysql://%db_hostname%:%mysql_port%/%mysql_db%?characterEncoding=UTF-8&autoReconnect=true&useSSL=false, user=%mysql_user%, account=null], DataSourceConfiguration [id=Postgres, protocol=null, host=null, port=null, db=null, type=POSTGRESQL, url=jdbc:postgresql://%db_hostname%:%postgres_port%/%postgres_db%, user=%postgres_user%, account=null]], environment={wf_protocol=http, wf_hostname=localhost, wf_port=15280, rpa_hub_hostname=localhost, rpa_hub_protocol=http, rpa_hub_port=15444, rpa_node_port=15410, db_hostname=localhost, mysql_port=15306, mysql_db=wfdb, mysql_user=mysqluser, mysql_password=mysqlpass, postgres_port=15423, postgres_db=virtualizer, postgres_user=pgsqluser, postgres_password=pgsqlpass, ocr_protocol=http, ocr_hostname=localhost, ocr_port=15580, apm_hostname=localhost}, dashboards=null, items={hubs=[{host=localhost, port=15444}]}, model=ModelConfig [backend='memory, source='null], commands=[CommandConfig [id=workfusion.start, type=http, schedule=null, expression=http://localhost:15100/api/processes/tomcat/start, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=workfusion.stop, type=http, schedule=null, expression=http://localhost:15100/api/processes/tomcat/stop, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=workfusion.open, type=command, schedule=null, expression=..\..\Applications\ChromiumPortable\ChromiumPortable.exe --proxy-server http://localhost:15280, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=s3storage.open, type=command, schedule=null, expression=..\..\Applications\ChromiumPortable\ChromiumPortable.exe --proxy-server http://localhost:15110, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=help.open, type=command, schedule=null, expression=..\..\Applications\ChromiumPortable\ChromiumPortable.exe --proxy-server https://kb.workfusion.com/display/RPAe, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpa-grid.open, type=command, schedule=null, expression=..\..\Applications\ChromiumPortable\ChromiumPortable.exe --proxy-server http://localhost:15100/rpa-grid, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=pm.open, type=command, schedule=null, expression=..\..\Applications\ChromiumPortable\ChromiumPortable.exe --proxy-server http://localhost:15100, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpa.recorder, type=command, schedule=null, expression=cmd.exe /c recorder.exe, source=null, credentials=null, parameters={directory=./../../Recorder, timeout=-1, wait=5000}, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpa.recorder.stop, type=command, schedule=null, expression=cmd.exe /c TASKKILL /IM recorder.exe /T /F, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=postgres.start, type=command, schedule=null, expression=cmd.exe /c bin\pg_ctl -D ..\data\postgresql -l pgsql.log start, source=null, credentials=null, parameters={directory=./../../Workfusion/postgresql, timeout=-1, wait=5000}, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=postgres.stop, type=command, schedule=null, expression=cmd.exe /c bin\pg_ctl -D ..\data\postgresql -l pgsql.log stop, source=null, credentials=null, parameters={directory=./../../Workfusion/postgresql, timeout=-1, wait=5000}, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpa.hub.start, type=http, schedule=null, expression=http://localhost:15100/api/processes/rpa.hub/start, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpa.hub.stop, type=http, schedule=null, expression=http://localhost:15100/api/processes/rpa.hub/stop, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpa.node.start, type=http, schedule=null, expression=http://localhost:15100/api/processes/rpa.node/start, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpa.node.stop, type=http, schedule=null, expression=http://localhost:15100/api/processes/rpa.node/stop, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=ocr.start, type=http, schedule=null, expression=http://localhost:15100/api/processes/ocr/start, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=ocr.stop, type=http, schedule=null, expression=http://localhost:15100/api/processes/ocr/stop, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpae.report, type=command, schedule=null, expression=powershell -ExecutionPolicy remotesigned -File rpae-report.ps1, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpae.logrotate, type=command, schedule=0 0 11 * * *, expression=powershell -ExecutionPolicy remotesigned -File logrotate.ps1, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null]], auth=DISABLED] failed:

    **Property: target.model**
**    Value: E5470**
**    Reason: Failed to convert property value of type 'java.lang.String' to required type 'com.workfusion.status.config.ModelConfig' for property 'model'; nested exception is java.lang.IllegalStateException: Cannot convert value of type 'java.lang.String' to required type 'com.workfusion.status.config.ModelConfig' for property 'model': no matching editors or conversion strategy found**
Action:

Update your application's configuration

Note: This is new thread created as suggested on : https://forum.workfusion.com/t/not-able-to-launch/2531/35[details=Summary]


#2

have you tried the solution from Not able to launch ?


#3

Yes, The solution provided in the earlier thread relates to 1) admin access (Full control) to RPAExpress folder in where the error message look like: Failed Java.io.FileNotFoundException 2) Internet Connectivity in where the error look like UnknownHostException.

The error which I am facing is entirely different and not related as said above. The Program is run with full admin access and with internet connectivity. The error relates to Property: target.model conversion

The error reason clearly states: Failed to convert property value of type ‘java.lang.String’ to required type ‘com.workfusion.status.config.ModelConfig’ for property ‘model’; nested exception is java.lang.IllegalStateException: Cannot convert value of type ‘java.lang.String’ to required type ‘com.workfusion.status.config.ModelConfig’ for property ‘model’: no matching editors or conversion strategy found

DETAIL LOG. FYI - Have attached all log files in earlier thread as well.


2017-05-29 13:10:05 [main] ERROR o.s.b.d.LoggingFailureAnalysisReporter -


APPLICATION FAILED TO START


Description:

Binding to target Config [components=[ComponentConfig [id=wf, name=Control Tower, group=wf, description=null, link=null, enabled=true, alerts=[wf.app], schedule=20], ComponentConfig [id=ws, name=WorkSpace, group=wf, description=null, link=null, enabled=true, alerts=[ws.app], schedule=20], ComponentConfig [id=ocr, name=OCR, group=ocr, description=null, link=null, enabled=true, alerts=null, schedule=60], ComponentConfig [id=rpa.hub, name=RPA Hub, group=rpa.grid, description=null, link=null, enabled=true, alerts=[rpa.hub], schedule=20], ComponentConfig [id=rpa.node, name=RPA Node, group=rpa.grid, description=null, link=null, enabled=true, alerts=[rpa.node], schedule=20], ComponentConfig [id=mysql, name=MySQL, group=db, description=null, link=null, enabled=true, alerts=[mysql], schedule=20], ComponentConfig [id=postgresql, name=PostgreSQL, group=db, description=null, link=null, enabled=true, alerts=[postgres], schedule=20]], groups=[GroupConfig [id=wf, name=Applications, collapsed=0], GroupConfig [id=rpa.grid, name=Bot Manager, collapsed=0], GroupConfig [id=ocr, name=OCR, collapsed=0], GroupConfig [id=db, name=Databases, collapsed=0]], alerts=[AlertConfig [id=ws.app, description=null, triggers=[AlertCheckConfig [metric=ws.app.status, type=MAJOR_OUTAGE, message=Web check failed, neq=0.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null], AlertCheckConfig [metric=ws.app.http.code, type=MAJOR_OUTAGE, message=WorkSpace is not responding properly, neq=200.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null]], enabled=true, dependson=null, templates=null, items=null], AlertConfig [id=wf.app, description=null, triggers=[AlertCheckConfig [metric=wf.app.status, type=MAJOR_OUTAGE, message=Web check failed, neq=0.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null], AlertCheckConfig [metric=wf.app.http.code, type=MAJOR_OUTAGE, message=WorkFusion is not responding properly, neq=200.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null]], enabled=true, dependson=null, templates=null, items=null], AlertConfig [id=rpa.hub, description=null, triggers=[AlertCheckConfig [metric=rpa.hub.status, type=MAJOR_OUTAGE, message=Web check failed, neq=0.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null], AlertCheckConfig [metric=rpa.hub.http.code, type=MAJOR_OUTAGE, message=RPA Hub is not responding properly, neq=200.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null]], enabled=true, dependson=null, templates=null, items=null], AlertConfig [id=rpa.node, description=null, triggers=[AlertCheckConfig [metric=rpa.node.status, type=MAJOR_OUTAGE, message=Web check failed, neq=0.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null], AlertCheckConfig [metric=rpa.node.http.code, type=MAJOR_OUTAGE, message=RPA Node is not responding properly, neq=200.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null]], enabled=true, dependson=null, templates=null, items=null], AlertConfig [id=mysql, description=null, triggers=[AlertCheckConfig [metric=mysql.query1.status, type=MAJOR_OUTAGE, message=Problem with mysql query, neq=0.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=3, dependson=null, interval=null]], enabled=true, dependson=null, templates=null, items=null], AlertConfig [id=postgres, description=null, triggers=[AlertCheckConfig [metric=postgres.query1.status, type=MAJOR_OUTAGE, message=Problem with postgres query, neq=0.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=3, dependson=null, interval=null]], enabled=true, dependson=null, templates=null, items=null]], checks=[CheckConfig [id=rpa.ct.disk, type=COMMAND, file=null, expression=wmic logicaldisk get size,freespace,caption, schedule=60, evaluate=[FunctionConfig [id=table.value.index, metric=, metricName=memfree, arg=0,C:,1, parameters={}, type=LONG, register=true, onFail=false], FunctionConfig [id=table.value.index, metric=, metricName=memtotal, arg=0,C:,2, parameters={}, type=LONG, register=true, onFail=false]], credentials=null, source=null, description=Get available disk space, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=rpa.ct.os, type=COMMAND, file=null, expression=wmic OS get Caption,OSArchitecture,FreePhysicalMemory,TotalVirtualMemorySize,FreeVirtualMemory,LastBootUpTime /format:list, schedule=60, evaluate=[FunctionConfig [id=properties, metric=null, metricName=null, arg=, parameters={}, type=LONG, register=true, onFail=false]], credentials=null, source=null, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=rpa.ct.computersystem, type=COMMAND, file=null, expression=wmic ComputerSystem get TotalPhysicalMemory /format:list, schedule=60, evaluate=[FunctionConfig [id=properties, metric=null, metricName=null, arg=, parameters={}, type=LONG, register=true, onFail=false]], credentials=null, source=null, description=Get total physical memory, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=rpa.ct.cpu, type=COMMAND, file=null, expression=wmic cpu get loadpercentage /format:list, schedule=60, evaluate=[FunctionConfig [id=properties, metric=null, metricName=null, arg=, parameters={}, type=LONG, register=true, onFail=false]], credentials=null, source=null, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=rpa.ct.java, type=COMMAND, file=null, expression=java -version, schedule=60, evaluate=[FunctionConfig [id=command.output, metric=, metricName=version, arg=, parameters={}, type=STRING, register=true, onFail=false]], credentials=null, source=null, description=Get java version, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=rpa.hub.slots, type=HTTP, file=null, expression=/grid/api/hub, schedule=30, evaluate=[FunctionConfig [id=http.json, metric=, metricName=waiting, arg=newSessionRequestCount, parameters={}, type=INT, register=true, onFail=false], FunctionConfig [id=http.json, metric=, metricName=free, arg=slotCounts.free, parameters={}, type=INT, register=true, onFail=false], FunctionConfig [id=http.json, metric=, metricName=max, arg=slotCounts.total, parameters={}, type=INT, register=true, onFail=false], FunctionConfig [id=expression, metric=, metricName=running, arg=%max% - %free%, parameters={}, type=INT, register=true, onFail=false]], credentials=null, source=RpaHub, description=Generate robot metrics from RPA Hub, parameters={request=GET, body={"configuration":["newSessionRequestCount","slotCounts"]}}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=rpa.hub, type=HTTP, file=null, expression=/grid/console, schedule=10, evaluate=[FunctionConfig [id=rpa.agent.items, metric=null, metricName=null, arg=nodes, parameters={}, type=LONG, register=true, onFail=false], FunctionConfig [id=tray.status.update, metric=null, metricName=null, arg=rpa, parameters={}, type=LONG, register=true, onFail=true]], credentials=null, source=RpaHub, description=Generates list of all nodes of a hub, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=rpa.node, type=HTTP, file=null, expression=/wd/hub/static/resource/hub.html, schedule=20, evaluate=null, credentials=null, source=RpaNode, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=wf.app, type=HTTP, file=null, expression=/workfusion/login, schedule=10, evaluate=[FunctionConfig [id=tray.status.update, metric=null, metricName=null, arg=workfusion, parameters={}, type=LONG, register=true, onFail=true]], credentials=null, source=WF, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=ws.app, type=HTTP, file=null, expression=/workspace/login, schedule=30, evaluate=null, credentials=null, source=WF, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=ocr.app, type=HTTP, file=null, expression=/, schedule=30, evaluate=[FunctionConfig [id=tray.status.update, metric=null, metricName=null, arg=ocr, parameters={}, type=LONG, register=true, onFail=true]], credentials=null, source=OCR, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=collector, type=JAVA, file=null, expression=null, schedule=60, evaluate=[FunctionConfig [id=action.events.log, metric=null, metricName=null, arg=, parameters={}, type=LONG, register=true, onFail=false]], credentials=null, source=null, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=mysql.query1, type=SQL, file=null, expression=select database() as db, schedule=60, evaluate=[FunctionConfig [id=sql.output, metric=, metricName=name, arg=db, parameters={}, type=STRING, register=true, onFail=false]], credentials=null, source=Mysql, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=postgres.query1, type=SQL, file=null, expression=select current_database() as db, schedule=60, evaluate=[FunctionConfig [id=sql.output, metric=, metricName=name, arg=db, parameters={}, type=STRING, register=true, onFail=false]], credentials=null, source=Postgres, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false]], datasources=[DataSourceConfiguration [id=WF, protocol=%wf_protocol%, host=%wf_hostname%, port=%wf_port%, db=null, type=HTTP, url=null, user=null, account=null], DataSourceConfiguration [id=OCR, protocol=%ocr_protocol%, host=%ocr_hostname%, port=%ocr_port%, db=null, type=HTTP, url=null, user=null, account=null], DataSourceConfiguration [id=RpaHub, protocol=%rpa_hub_protocol%, host=%rpa_hub_hostname%, port=%rpa_hub_port%, db=null, type=HTTP, url=null, user=null, account=null], DataSourceConfiguration [id=RpaNode, protocol=%rpa_hub_protocol%, host=%rpa_hub_hostname%, port=%rpa_node_port%, db=null, type=HTTP, url=null, user=null, account=null], DataSourceConfiguration [id=Mysql, protocol=null, host=null, port=null, db=null, type=MYSQL, url=jdbc:mysql://%db_hostname%:%mysql_port%/%mysql_db%?characterEncoding=UTF-8&autoReconnect=true&useSSL=false, user=%mysql_user%, account=null], DataSourceConfiguration [id=Postgres, protocol=null, host=null, port=null, db=null, type=POSTGRESQL, url=jdbc:postgresql://%db_hostname%:%postgres_port%/%postgres_db%, user=%postgres_user%, account=null]], environment={wf_protocol=http, wf_hostname=localhost, wf_port=15280, rpa_hub_hostname=localhost, rpa_hub_protocol=http, rpa_hub_port=15444, rpa_node_port=15410, db_hostname=localhost, mysql_port=15306, mysql_db=wfdb, mysql_user=mysqluser, mysql_password=mysqlpass, postgres_port=15423, postgres_db=virtualizer, postgres_user=pgsqluser, postgres_password=pgsqlpass, ocr_protocol=http, ocr_hostname=localhost, ocr_port=15580, apm_hostname=localhost}, dashboards=null, items={hubs=[{host=localhost, port=15444}]}, model=ModelConfig [backend='memory, source='null], commands=[CommandConfig [id=workfusion.start, type=http, schedule=null, expression=http://localhost:15100/api/processes/tomcat/start, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=workfusion.stop, type=http, schedule=null, expression=http://localhost:15100/api/processes/tomcat/stop, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=workfusion.open, type=command, schedule=null, expression=..\..\Applications\ChromiumPortable\ChromiumPortable.exe --proxy-server http://localhost:15280, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=s3storage.open, type=command, schedule=null, expression=..\..\Applications\ChromiumPortable\ChromiumPortable.exe --proxy-server http://localhost:15110, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=help.open, type=command, schedule=null, expression=..\..\Applications\ChromiumPortable\ChromiumPortable.exe --proxy-server https://kb.workfusion.com/display/RPAe, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpa-grid.open, type=command, schedule=null, expression=..\..\Applications\ChromiumPortable\ChromiumPortable.exe --proxy-server http://localhost:15100/rpa-grid, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=pm.open, type=command, schedule=null, expression=..\..\Applications\ChromiumPortable\ChromiumPortable.exe --proxy-server http://localhost:15100, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpa.recorder, type=command, schedule=null, expression=cmd.exe /c recorder.exe, source=null, credentials=null, parameters={directory=./../../Recorder, timeout=-1, wait=5000}, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpa.recorder.stop, type=command, schedule=null, expression=cmd.exe /c TASKKILL /IM recorder.exe /T /F, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=postgres.start, type=command, schedule=null, expression=cmd.exe /c bin\pg_ctl -D ..\data\postgresql -l pgsql.log start, source=null, credentials=null, parameters={directory=./../../Workfusion/postgresql, timeout=-1, wait=5000}, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=postgres.stop, type=command, schedule=null, expression=cmd.exe /c bin\pg_ctl -D ..\data\postgresql -l pgsql.log stop, source=null, credentials=null, parameters={directory=./../../Workfusion/postgresql, timeout=-1, wait=5000}, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpa.hub.start, type=http, schedule=null, expression=http://localhost:15100/api/processes/rpa.hub/start, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpa.hub.stop, type=http, schedule=null, expression=http://localhost:15100/api/processes/rpa.hub/stop, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpa.node.start, type=http, schedule=null, expression=http://localhost:15100/api/processes/rpa.node/start, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpa.node.stop, type=http, schedule=null, expression=http://localhost:15100/api/processes/rpa.node/stop, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=ocr.start, type=http, schedule=null, expression=http://localhost:15100/api/processes/ocr/start, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=ocr.stop, type=http, schedule=null, expression=http://localhost:15100/api/processes/ocr/stop, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpae.report, type=command, schedule=null, expression=powershell -ExecutionPolicy remotesigned -File rpae-report.ps1, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpae.logrotate, type=command, schedule=0 0 11 * * *, expression=powershell -ExecutionPolicy remotesigned -File logrotate.ps1, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null]], auth=DISABLED] failed:

    Property: target.model
    Value: E5470
    Reason: Failed to convert property value of type 'java.lang.String' to required type 'com.workfusion.status.config.ModelConfig' for property 'model'; nested exception is java.lang.IllegalStateException: Cannot convert value of type 'java.lang.String' to required type 'com.workfusion.status.config.ModelConfig' for property 'model': no matching editors or conversion strategy found

Action:

Update your application's configuration

*************************************************************************************************************************

Let me know if the above details are sufficient for further investigation.


#4

Hi everyone,

I’ve got the problem that the RPA Express Launch gets stuck during startup.

I already checked the troubleshooting at https://kb.workfusion.com/display/RPAe/Troubleshooting#expand-RPAExpresslaunchgetsstuckshowingsplashscreen. This didn’t work for me.

In the logfile I found the following entry. The proposed solution is to update the application’s configuration.

Can someone help me please?

Error starting ApplicationContext. To display the auto-configuration report re-run your application with ‘debug’ enabled.
2017-06-07 17:32:45 [main] ERROR o.s.b.d.LoggingFailureAnalysisReporter -


APPLICATION FAILED TO START


Description:

Binding to target Config [components=[ComponentConfig [id=wf, name=Control Tower, group=wf, description=null, link=null, enabled=true, alerts=[wf.app], schedule=20], ComponentConfig [id=ws, name=WorkSpace, group=wf, description=null, link=null, enabled=true, alerts=[ws.app], schedule=20], ComponentConfig [id=ocr, name=OCR, group=ocr, description=null, link=null, enabled=true, alerts=null, schedule=60], ComponentConfig [id=rpa.hub, name=RPA Hub, group=rpa.grid, description=null, link=null, enabled=true, alerts=[rpa.hub], schedule=20], ComponentConfig [id=rpa.node, name=RPA Node, group=rpa.grid, description=null, link=null, enabled=true, alerts=[rpa.node], schedule=20], ComponentConfig [id=mysql, name=MySQL, group=db, description=null, link=null, enabled=true, alerts=[mysql], schedule=20], ComponentConfig [id=postgresql, name=PostgreSQL, group=db, description=null, link=null, enabled=true, alerts=[postgres], schedule=20]], groups=[GroupConfig [id=wf, name=Applications, collapsed=0], GroupConfig [id=rpa.grid, name=Bot Manager, collapsed=0], GroupConfig [id=ocr, name=OCR, collapsed=0], GroupConfig [id=db, name=Databases, collapsed=0]], alerts=[AlertConfig [id=ws.app, description=null, triggers=[AlertCheckConfig [metric=ws.app.status, type=MAJOR_OUTAGE, message=Web check failed, neq=0.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null], AlertCheckConfig [metric=ws.app.http.code, type=MAJOR_OUTAGE, message=WorkSpace is not responding properly, neq=200.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null]], enabled=true, dependson=null, templates=null, items=null], AlertConfig [id=wf.app, description=null, triggers=[AlertCheckConfig [metric=wf.app.status, type=MAJOR_OUTAGE, message=Web check failed, neq=0.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null], AlertCheckConfig [metric=wf.app.http.code, type=MAJOR_OUTAGE, message=WorkFusion is not responding properly, neq=200.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null]], enabled=true, dependson=null, templates=null, items=null], AlertConfig [id=rpa.hub, description=null, triggers=[AlertCheckConfig [metric=rpa.hub.status, type=MAJOR_OUTAGE, message=Web check failed, neq=0.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null], AlertCheckConfig [metric=rpa.hub.http.code, type=MAJOR_OUTAGE, message=RPA Hub is not responding properly, neq=200.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null]], enabled=true, dependson=null, templates=null, items=null], AlertConfig [id=rpa.node, description=null, triggers=[AlertCheckConfig [metric=rpa.node.status, type=MAJOR_OUTAGE, message=Web check failed, neq=0.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null], AlertCheckConfig [metric=rpa.node.http.code, type=MAJOR_OUTAGE, message=RPA Node is not responding properly, neq=200.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=1, dependson=null, interval=null]], enabled=true, dependson=null, templates=null, items=null], AlertConfig [id=mysql, description=null, triggers=[AlertCheckConfig [metric=mysql.query1.status, type=MAJOR_OUTAGE, message=Problem with mysql query, neq=0.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=3, dependson=null, interval=null]], enabled=true, dependson=null, templates=null, items=null], AlertConfig [id=postgres, description=null, triggers=[AlertCheckConfig [metric=postgres.query1.status, type=MAJOR_OUTAGE, message=Problem with postgres query, neq=0.0, eq=null, gte=null, gt=null, lte=null, lt=null, neqs=null, eqs=null, gtes=null, gts=null, ltes=null, lts=null, points=3, dependson=null, interval=null]], enabled=true, dependson=null, templates=null, items=null]], checks=[CheckConfig [id=rpa.ct.disk, type=COMMAND, file=null, expression=wmic logicaldisk get size,freespace,caption, schedule=60, evaluate=[FunctionConfig [id=table.value.index, metric=, metricName=memfree, arg=0,C:,1, parameters={}, type=LONG, register=true, onFail=false], FunctionConfig [id=table.value.index, metric=, metricName=memtotal, arg=0,C:,2, parameters={}, type=LONG, register=true, onFail=false]], credentials=null, source=null, description=Get available disk space, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=rpa.ct.os, type=COMMAND, file=null, expression=wmic OS get Caption,OSArchitecture,FreePhysicalMemory,TotalVirtualMemorySize,FreeVirtualMemory,LastBootUpTime /format:list, schedule=60, evaluate=[FunctionConfig [id=properties, metric=null, metricName=null, arg=, parameters={}, type=LONG, register=true, onFail=false]], credentials=null, source=null, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=rpa.ct.computersystem, type=COMMAND, file=null, expression=wmic ComputerSystem get TotalPhysicalMemory /format:list, schedule=60, evaluate=[FunctionConfig [id=properties, metric=null, metricName=null, arg=, parameters={}, type=LONG, register=true, onFail=false]], credentials=null, source=null, description=Get total physical memory, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=rpa.ct.cpu, type=COMMAND, file=null, expression=wmic cpu get loadpercentage /format:list, schedule=60, evaluate=[FunctionConfig [id=properties, metric=null, metricName=null, arg=, parameters={}, type=LONG, register=true, onFail=false]], credentials=null, source=null, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=rpa.ct.java, type=COMMAND, file=null, expression=java -version, schedule=60, evaluate=[FunctionConfig [id=command.output, metric=, metricName=version, arg=, parameters={}, type=STRING, register=true, onFail=false]], credentials=null, source=null, description=Get java version, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=rpa.hub.slots, type=HTTP, file=null, expression=/grid/api/hub, schedule=30, evaluate=[FunctionConfig [id=http.json, metric=, metricName=waiting, arg=newSessionRequestCount, parameters={}, type=INT, register=true, onFail=false], FunctionConfig [id=http.json, metric=, metricName=free, arg=slotCounts.free, parameters={}, type=INT, register=true, onFail=false], FunctionConfig [id=http.json, metric=, metricName=max, arg=slotCounts.total, parameters={}, type=INT, register=true, onFail=false], FunctionConfig [id=expression, metric=, metricName=running, arg=%max% - %free%, parameters={}, type=INT, register=true, onFail=false]], credentials=null, source=RpaHub, description=Generate robot metrics from RPA Hub, parameters={request=GET, body={"configuration":["newSessionRequestCount","slotCounts"]}}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=rpa.hub, type=HTTP, file=null, expression=/grid/console, schedule=10, evaluate=[FunctionConfig [id=rpa.agent.items, metric=null, metricName=null, arg=nodes, parameters={}, type=LONG, register=true, onFail=false], FunctionConfig [id=tray.status.update, metric=null, metricName=null, arg=rpa, parameters={}, type=LONG, register=true, onFail=true]], credentials=null, source=RpaHub, description=Generates list of all nodes of a hub, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=rpa.node, type=HTTP, file=null, expression=/wd/hub/static/resource/hub.html, schedule=20, evaluate=null, credentials=null, source=RpaNode, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=wf.app, type=HTTP, file=null, expression=/workfusion/login, schedule=10, evaluate=[FunctionConfig [id=tray.status.update, metric=null, metricName=null, arg=workfusion, parameters={}, type=LONG, register=true, onFail=true]], credentials=null, source=WF, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=ws.app, type=HTTP, file=null, expression=/workspace/login, schedule=30, evaluate=null, credentials=null, source=WF, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=ocr.app, type=HTTP, file=null, expression=/, schedule=30, evaluate=[FunctionConfig [id=tray.status.update, metric=null, metricName=null, arg=ocr, parameters={}, type=LONG, register=true, onFail=true]], credentials=null, source=OCR, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=collector, type=JAVA, file=null, expression=null, schedule=60, evaluate=[FunctionConfig [id=action.events.log, metric=null, metricName=null, arg=, parameters={}, type=LONG, register=true, onFail=false]], credentials=null, source=null, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=mysql.query1, type=SQL, file=null, expression=select database() as db, schedule=60, evaluate=[FunctionConfig [id=sql.output, metric=, metricName=name, arg=db, parameters={}, type=STRING, register=true, onFail=false]], credentials=null, source=Mysql, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false], CheckConfig [id=postgres.query1, type=SQL, file=null, expression=select current_database() as db, schedule=60, evaluate=[FunctionConfig [id=sql.output, metric=, metricName=name, arg=db, parameters={}, type=STRING, register=true, onFail=false]], credentials=null, source=Postgres, description=null, parameters={}, tag=, templates=null, items=null, enabled=true, dependson=null, ns=, sslFactory=false]], datasources=[DataSourceConfiguration [id=WF, protocol=%wf_protocol%, host=%wf_hostname%, port=%wf_port%, db=null, type=HTTP, url=null, user=null, account=null], DataSourceConfiguration [id=OCR, protocol=%ocr_protocol%, host=%ocr_hostname%, port=%ocr_port%, db=null, type=HTTP, url=null, user=null, account=null], DataSourceConfiguration [id=RpaHub, protocol=%rpa_hub_protocol%, host=%rpa_hub_hostname%, port=%rpa_hub_port%, db=null, type=HTTP, url=null, user=null, account=null], DataSourceConfiguration [id=RpaNode, protocol=%rpa_hub_protocol%, host=%rpa_hub_hostname%, port=%rpa_node_port%, db=null, type=HTTP, url=null, user=null, account=null], DataSourceConfiguration [id=Mysql, protocol=null, host=null, port=null, db=null, type=MYSQL, url=jdbc:mysql://%db_hostname%:%mysql_port%/%mysql_db%?characterEncoding=UTF-8&autoReconnect=true&useSSL=false, user=%mysql_user%, account=null], DataSourceConfiguration [id=Postgres, protocol=null, host=null, port=null, db=null, type=POSTGRESQL, url=jdbc:postgresql://%db_hostname%:%postgres_port%/%postgres_db%, user=%postgres_user%, account=null]], environment={wf_protocol=http, wf_hostname=localhost, wf_port=15280, rpa_hub_hostname=localhost, rpa_hub_protocol=http, rpa_hub_port=15444, rpa_node_port=15410, db_hostname=localhost, mysql_port=15306, mysql_db=wfdb, mysql_user=mysqluser, mysql_password=mysqlpass, postgres_port=15423, postgres_db=virtualizer, postgres_user=pgsqluser, postgres_password=pgsqlpass, ocr_protocol=http, ocr_hostname=localhost, ocr_port=15580, apm_hostname=localhost}, dashboards=null, items={hubs=[{host=localhost, port=15444}]}, model=ModelConfig [backend='memory, source='null], commands=[CommandConfig [id=workfusion.start, type=http, schedule=null, expression=http://localhost:15100/api/processes/tomcat/start, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=workfusion.stop, type=http, schedule=null, expression=http://localhost:15100/api/processes/tomcat/stop, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=workfusion.open, type=command, schedule=null, expression=..\..\Applications\ChromiumPortable\ChromiumPortable.exe --proxy-server http://localhost:15280, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=s3storage.open, type=command, schedule=null, expression=..\..\Applications\ChromiumPortable\ChromiumPortable.exe --proxy-server http://localhost:15110, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=help.open, type=command, schedule=null, expression=..\..\Applications\ChromiumPortable\ChromiumPortable.exe --proxy-server https://kb.workfusion.com/display/RPAe, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpa-grid.open, type=command, schedule=null, expression=..\..\Applications\ChromiumPortable\ChromiumPortable.exe --proxy-server http://localhost:15100/rpa-grid, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=pm.open, type=command, schedule=null, expression=..\..\Applications\ChromiumPortable\ChromiumPortable.exe --proxy-server http://localhost:15100, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpa.recorder, type=command, schedule=null, expression=cmd.exe /c recorder.exe, source=null, credentials=null, parameters={directory=./../../Recorder, timeout=-1, wait=5000}, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpa.recorder.stop, type=command, schedule=null, expression=cmd.exe /c TASKKILL /IM recorder.exe /T /F, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=postgres.start, type=command, schedule=null, expression=cmd.exe /c bin\pg_ctl -D ..\data\postgresql -l pgsql.log start, source=null, credentials=null, parameters={directory=./../../Workfusion/postgresql, timeout=-1, wait=5000}, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=postgres.stop, type=command, schedule=null, expression=cmd.exe /c bin\pg_ctl -D ..\data\postgresql -l pgsql.log stop, source=null, credentials=null, parameters={directory=./../../Workfusion/postgresql, timeout=-1, wait=5000}, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpa.hub.start, type=http, schedule=null, expression=http://localhost:15100/api/processes/rpa.hub/start, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpa.hub.stop, type=http, schedule=null, expression=http://localhost:15100/api/processes/rpa.hub/stop, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpa.node.start, type=http, schedule=null, expression=http://localhost:15100/api/processes/rpa.node/start, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpa.node.stop, type=http, schedule=null, expression=http://localhost:15100/api/processes/rpa.node/stop, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=ocr.start, type=http, schedule=null, expression=http://localhost:15100/api/processes/ocr/start, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=ocr.stop, type=http, schedule=null, expression=http://localhost:15100/api/processes/ocr/stop, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpae.report, type=command, schedule=null, expression=powershell -ExecutionPolicy remotesigned -File rpae-report.ps1, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null], CommandConfig [id=rpae.logrotate, type=command, schedule=0 0 11 * * *, expression=powershell -ExecutionPolicy remotesigned -File logrotate.ps1, source=null, credentials=null, parameters=null, items=null, alerts=null, templates=null, enabled=true, ns=null]], auth=DISABLED, units=null] failed:

    Property: target.Model
    Value: 225A
    Reason: Failed to convert property value of type 'java.lang.String' to required type 'com.workfusion.status.config.ModelConfig' for property 'Model'; nested exception is java.lang.IllegalStateException: Cannot convert value of type 'java.lang.String' to required type 'com.workfusion.status.config.ModelConfig' for property 'Model': no matching editors or conversion strategy found

Action:

Update your application’s configuration


#5

Hi, Been stuck with the issue for long. Any updates/workaround(s) on the above said issue?


#6

Hi @Sri_Rama_Kanth_N, we have not been able to solve the issue yet.


#7

Hi @Deike_Muller, Nope - been trying to followup in the forum but no success yet. Interim tried changing system variables etc., but nothing works and still stuck with same error.


#8

@azinchuk can you maybe help us with our issue?


#9

@Sri_Rama_Kanth_N - have you tried to update to the latest 1.1.1 version? On the 15th of June we will release the 1.1.2 version with a lot of issues fixed - you can try the new one


#10

@azinchuk Thanks for the reply! I have tried installing the latest version and still have the same problem. I will try to reinstall on June 15th and let you know if that solved the issue.


#11

Hi @azinchuk, Yes tried with 1.1.0-beta and later with 1.1.1-beta the issue remains same as Deike confirmed. Is there any probable root cause/insights from tech team to point out mismatch on the model etc., before retry on 1.1.2?


#12

Installed the newest version, yet the issue remains. @Sri_Rama_Kanth_N Do you still have the issue as well? Or were you able to solve it? @azinchuk Any pin pointers as how to solve it?


#13

Hi @Deike_Muller, I have same issue, no luck with latest version 1.1.2-beta as well. There seems some fundamental issue. @azinchuk - Its now high time to delve into issue details/root cause , appreciate your help in trouble shooting the issue.


#14

Any update @azinchuk ? We have tried to install the software on mulitple devices now, no luck so far. Looking at the error message it seems to be something that could be fixed on your side.


#15

@Deike_Muller - we will get back to you when we reproduce this issue.


#16

Sounds good! Appreciate the support. If you need any more information on the issue to speed up the process, I am happy to help.


#17

Hi @Deike_Muller, Any luck in reproducing the issue?. Are they any aspects to looked out for to narrow down the possible causes?


#18

No luck so far. I am trying to schedule a screen share session with @pooja at the moment to fix this issue.


#19

@Deike_Muller, @Sri_Rama_Kanth_N

Please send us the wfagent-1(2,3).YML files from ${your_install_dir}\RPAExpress\RPA\wfagent


#20

wfagent-3.txt (264 Bytes)
wfagent-2.txt (264 Bytes)
wfagent-1.txt (3.0 KB)
@azinchuk I wasnt able to upload them as .yml files so I converted them to .txt. If you need the original files I can send them to you by mail.
FYI @pooja