Failed to execute Action OCR Action

ocr

#1

Hi All,

I am getting below error in OCR action when i run the recorder. What could be the reason. doing OCR action in 4th step and this is the last step in recorder.

Error : Failed to execute Action OcrAction
java.lang.RuntimeException: Failed to execute Action OcrAction
at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.execute(ActionFlowPlayer.java:311)
at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.processAction(ActionFlowPlayer.java:256)
at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.lambda$1(ActionFlowPlayer.java:120)
at java.util.ArrayList.forEach(ArrayList.java:1249)
at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.lambda$0(ActionFlowPlayer.java:120)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)


#2

Quick question : did you start the ocr ?


#3

I am also getting same error “Failed to execute Action OcrAction”.


#4

yes. OCR is running.


#5

Capture the image again, and set the OCR area properly.
It should be redirected to the same page and even resolution/zoom of the page must be exact to fetch the data from OCR, otherwise OCR will fail to detect it.


#6

The same issue persists for me too. I am using 1.1.3 Beta version


#7

are you guys using the 1st version of 1.1.3 or the updated version of 1.1.3? OCR does not work for the 1st version. Redownload the installation file and reinstall it shall work.


#8

I get the same error. However, the OCR action is included in my script twice and the first it time everything goes well. At the second time the action should be executed, the error appears. The OCR is executed in the same PDF file.

Anyone with a solution?


#9

@admins

Hi,

OCR was running fine yesterday. today it’s not working and getting the same exception ‘Failed to execute OCR Action’.

I dint do any modifications for my script today and trying to run the yesterday’s script only.

I have restated the WorkFusion and system also but no luck.


#10
  1. Which version
  2. send me all logs from INSTALL_DIR/OCR/logs
    (just add whole folder to zip)

#11

@mzhalniarkevich

Version 1.1.3-beta

logs.rar (63.4 KB)


#12

Caused by: java.io.IOException: An established connection was aborted by the software in your host machine

Probably your antivirus is blocking something


#13

@mzhalniarkevich

How to resolve this then.


#14

Check whats your antivirus is blocking (from our software or install_DIR) and add it to exception