Fatal error: Error 0x80070643: Failed to execute MSI package

installation
issues

#1

Hi. During Workfusion RPA express installation, it failed with error message as FATAL error.
Error 0x80070643: Failed to execute MSI package.
I tried installing again multiple times, even disabling Firewall but no luck.
I am attaching both logfiles (one generated during set up and other generated in temp folder)Workfusion_RPA_Express_logiles.zip (8.7 MB)
Please suggest.


#2

@Mohit_Sharma1 - please check our troubleshooting guide - https://kb.workfusion.com/display/RPAe/Troubleshooting#expand-Errorcode0x80070643


#3

Hi Rpa Team,
i am getting error when i was installing in windows 7 but it was auto roll out and gives fatal error.
here is below erroe log report.
[17DC:14C4][2017-11-06T18:38:49]e000: Error 0x80070643: Failed to install MSI package.
[17DC:14C4][2017-11-06T18:38:49]e000: Error 0x80070643: Failed to execute MSI package.
[1524:13A8][2017-11-06T18:38:49]e000: Error 0x80070643: Failed to configure per-machine MSI package.
[1524:13A8][2017-11-06T18:38:49]i319: Applied execute package: WorkFusionRPAExpress.msi, result: 0x80070643, restart: None
[1524:13A8][2017-11-06T18:38:49]e000: Error 0x80070643: Failed to execute MSI package.
[17DC:14C4][2017-11-06T18:38:49]i318: Skipped rollback of package: WorkFusionRPAExpress.msi, action: Uninstall, already: Absent
[1524:13A8][2017-11-06T18:38:49]i319: Applied rollback package: WorkFusionRPAExpress.msi, result: 0x0, restart: None
[17DC:14C4][2017-11-06T18:38:49]i329: Removed package dependency provider: {940B81FE-080D-4F90-9869-DFDF869F73FD}, package: WorkFusionRPAExpress.msi
[17DC:14C4][2017-11-06T18:38:49]i351: Removing cached package: WorkFusionRPAExpress.msi, from path: C:\ProgramData\Package Cache{940B81FE-080D-4F90-9869-DFDF869F73FD}v1.1.7
[17DC:14C4][2017-11-06T18:38:49]i372: Session end, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall{7cd546ad-0a2d-4b94-b369-cd817b5dcbb4}, resume: None, restart: None, disable resume: No
[17DC:14C4][2017-11-06T18:38:49]i330: Removed bundle dependency provider: {7cd546ad-0a2d-4b94-b369-cd817b5dcbb4}


#4

Hi,
This is not solution but can you restart the system and again try may be your problem will resolve
Thanks
Sharad Kumar


#5

Per direction from Maksym at WorkFusion Support, I’m logging in the WorkFusion Forum that we are also experiencing the 0x80070643 error installing RPA Express 1.1.6. None of the noted reasons in the KB article (corrupt files, antivirus, anti-malware) are the cause. We have also tried changing firewall settings. Are there any other potential causes we should be considering?


#6

In our case, what we learned is that the installer assumes the firewall service is active. We were not running the firewall service.Thus we had to activate the firewall service, run the installer, and then deactivate the firewall service.