Finding a specific sheet in an Excel workbook doesn´t work

Thanks. Please change “Type” from CSS to Object and then check the selector. You need to use it in your Mouse Click action.

Hi,

I have changed from CSS to Object, but every time i go back to the Inspector it is changed back to CSS. How can i save this action?

It shows CSS by default, I don’t think that it can be saved. Can you please put this Object selector to your action and check how it works?

Hi again,

We have tried both selectors below and no one of them is working. It doesnt left click on the sheet we want it to. (SHB Rådata).

Please note that the first selector we used (top of thread) used to work, but not any more. So how do we get the robot to left click on sheet we want?

[CSS:.TabItem[name=“Sheet SHB Rådata”]]

Could you please advise your Excel version?

It is 2013

One more clarification. Did you update your Windows or Office recently? You mentioned that your selector worked previously. Can you advise when it stopped work? Did this happen after update?

When it worked, it was done in Excel 2016 (on local desktop). But when we moved the processes to another server it stopped working. The server is using Excel 2013.

Thanks. And please advise your RPA Express version. You can find it in Control Panel - Programs and Features:

Thank you.
Looks like your issue is with Excel. Do you have any possibility to install Excel 2016 on the server? I received the information that Windows selectors can be different for different Office versions.

Yes, we are looking into that now. Hopefully it won´t take to long.
Thanks

Hi, @tomas.axelsson are there any news?

Hi,
We are in the progress to update to Office 2016. Hopefully sometime during next week.

3 Likes

Hi,

We have now updated to Excel 2016 but we still don´t get this part to work.
Running the Inspector, not sure if it is relevant, you can see in the print screen that it marks the whole sheet but not the tabs. N

Hi @tomas.axelsson.
It looks like known bug. Could you please provide your Excel version number? You can find it in Excel tab File - Account - About Excel, please see my example below:
image

image

Hello Tomas.
Thanks for the information. We already have this bug and escalated it to development team for fix. Currently we don’ have any estimations, but if you wish, you can watch this thread: Inspector doesn't see empty cells in Excel.

As a workaround, I can suggest to try to use built-in Excel actions to work with Excel files in background (this will work only for file types .xls, .xlsx) or use image-based actions without Window control option.

Hi,

We have now tried to use the “Go To” function in Excel. This works fine doing it manually but in the RPA process the robot doesn´t seem to understand that we shifted window even though we can see that the robot have shifted window. Is not able to write in the “Go To” window. It is just blinking and nothing more happens. We have noticed the same problem in another RPA process where we want to add a workbook to outlook and then send an email. The robot doesn´t seem to understand that it has shifted to outlook.

Hello @tomas.axelsson.
That’s why we recommend to define active window to make sure that bot enters or clicks in the required window. I’ve just checked on my side using selector for “Go To” window from Inspector. Please see my screenshots below:

  1. Actions flow:
    image
  2. Settings of the second “Window” from Inspector (the Window selector might be different in your Excel version):
    image