Getting switch window error while trying to play recording

While creating recording whenever I am trying to navigate to a window explorer, or using win+R command to open explorer/ application. For one of the recording I followed following steps:

  1. Clicked on file explorer
  2. Navigated to ‘This PC’ window
  3. Tried to click on D drive (bot Failed, throw switch window error)

Another example

  1. Enter command win+R and tried to open calculator (got switch window error)

Can anyone please help me to get this issue resolved?

Could you share the recording that fails and the text of the error?

Thank you.

Yes, sure.
Today I got switch window action error again, while trying to click firefox browser icon available on window tray.

SwitchWindowError.txt (6.8 KB)
I am sharing UI error and detailed error in notepad. How to share recording ?

You need to go to your workspace (C:\Users\user\workfusion-workspace\rpae_project by default), zip the folder with the recording and post here.

Recording:
OpenGoogle.zip (974.1 KB)

1 Like

Thank you @pragateekanjilal

Which version of RPA Express are you using?

It looks like this flow was recorded using 2.1.5 or earlier that had a bug with keystrokes.

Try updating to 2.2 and let us know if you still have this issue with that version.

Im using the latest version but i got the error in this situation.
First i use win keystroke to open excel file
Then i move to other app
Then when i try to return open a new excel file by using win keystroke again and it cannot enter any word to the window, everything is entered in the second step’s app.
What should i do?

Do you switch to the window before entering any keystrokes in it?

Can you tell me what is the window name? I had tried to switch to start window but i did not work correctly.

Hi @annguyen check out this topic