How to add mail id in recorder Variable?

Hi Team,

How to add mail id in recorder variable to use it in updating online form. Mail id has multiple special character like @, .

Please suggest.

@sandeep_timma You should be able to write these characters in the recorder variable with no issues.
Do you have any problems with this?

Hi Team,

When I am entering mail id in Name section and selected string Type. But the mail id is not getting saved and it is getting highlighted in Red color.

The name can contain only lowercase letters, digits and underscores, i.e. mail_id

Hi Team,

I am putting the mail id in below format. let me know if anything is incorrect
xxx.yyy@xyz.com

@sandeep_timma Please share the screenshot of the issue you have.

@sandeep_timma you can add the email address in the variable in such format. There shouldn’t be any issues.

image

Hello !
I’m also not able to use email as a variable.
I set the variable in RPA as you described but when the bot try to log in the web browser, the character “@” is substituted by “à”.
Do you have any idea to help me please?
Scr2Scr1

@francois_czaDq Maybe, you have a different keyboard language at the time of execution?

@ashapkina No, it is the same as I use usually, which is the French keyboard. But it just tried to change my keyboard to the English one before executing the script and it is done correctly.
So, change the keyboard in English seems to be a solution.
Thank you for your help !

1 Like

I’m glad you managed to make it work :+1:

hi, i have a problem with a dot and “@” symbol in Variables setup. Please see screenshot. How can it be fixed?
Thank you. RPA Express 2.0.1.
ErrorEmail.docx (477.7 KB)

Hi Inga, what is the language of the keyboard at this time?
If you need to insert the text in English, the keyboard should be in English, too.

It is English both.

Strange, usually this problem occurs when the keyboard language is wrong.
Could you share your recording or a screenshot of it?

ok, will try

1 Like

The first screen is unlogged Google screen, this page catches belorussian language according to my ip address.ErrorEmail2.docx (524.8 KB)

Any idea to help me???

Additional information, tried to use different languages of the keyboard.
For Ru: there is no problem with ‘dot’ , but ‘@’ is still ignored.
For En (US) , ‘dot’ displays as ‘’ and ‘@’ is still ignored.
How it can be fixed?

@iostroumova could you post your recording here?