How to deploy bot


#1

Hello,

I would like to know how to deploy and manage bot that I have made using WorkFusion RPA Express on somebody’s else machine which does not have WorkFusion RPA Express.
And also how to use and manage someone’s else bot in my system. I tried using import package under view all Business Processes but it is giving error which is
Package cannot be imported correctly because it has invalid structure. Further import is unavailable.

Thank You
Mehar Singh


#2

@mehar_singhjUg

Hi Mehar,
You cannot deploy your bot on a machine that doesn’t have RPA Express.
However, you should be able to import someone else’s business process into Control Tower. Please send us the package you failed to import, we’ll see what might have caused the error.

Alesia


#3

stock.zip (2.4 KB)
stock.xlsx (5.9 KB)
PFA
Let me know what is the procedure for importing and running the package from business process.

Thank you


#4

One way is to just copy the RPAe files and publish it to the control tower on your computer


#5

@mehar_singhjUg

Hi Mehar, @Darcy’s approach is correct in this situation. You can just copy the folder to your workspace and publish the recording to the Control Tower from the RPA Recorder.

To import a business process from one Control Tower to another one, you need to create a package from an existing business process in Control Tower (New Package button in the Business Process Packages tab).


Then you can download it and import it into another user’s Control Tower.
You cannot import RPAe files.


#6

Sorry for the late reply
I tried this way but after clicking on Run This Process in guest Control Tower, it did not actually run even though it gave a running symbol .After that i found out these error(In attachment).
P.S I also uploaded the data required for the bot to run in guest system.
Any explanation on this and any suggestion for sorting this problem.

events_root_32053c3e-844f-4982-9b1b-472a57a39d14_2018-01-02 11-12-51.xlsx (8.5 KB)

Thanks


#7

@mehar_singhjUg
Did you publish it to Control Tower from RPA Recorder? Did it work in the recorder?


#8

Yes, I did published it to my Control Tower and it is working on my local Control Tower as well as in recorder.


#9

For the reference
the zip is (downloaded from my control tower)
NewStock Process 05-1-2018.zip (4.9 KB)

Input data csv is (variables list)
65c45ac1-191a-4aa1-9f1b-cc61271d6b02.csv (193 Bytes)

and file from which it will read data is
stock.xlsx (6.0 KB)


#10

I have this same issue. When I’m importing a package in Control Tower and running it, it shows the same error. Can anyone provide a solution to this?


#11

@mehar_singhjUg @ankit_kumarUbp
What is the version of the control tower you are importing the package to? Is it the same as the control tower where you created it?


#12

@ashapkina I have created the package in version 1.1.8-beta and importing it to the same. If possible, please provide a step-by-step guide or a video tutorial on how to publish own project on local Control Tower so that it can be imported to another machine successfully and then import and run on another machine’s Control Tower successfully.


#13

@ankit_kumarUbp
Hi Ankit, we are planning to publish a guide on working with business processes in Control Tower by the end of January-start of February.

Alesia


#14

Please let me know how to deploy Workfusion rpa bot from my local machine to some other machine using Control Tower.