How to select particular cell in a table

table contains 5(row)*5(column) data ,now how can I select 2(row)*5(column).can you please help on this issue.

@lakshmipriya_a you can do it using a custom script or a Constant value action as described in this topic

sorry I forget to mention based on row condition, how to select the cell .

for eg: if row contains today date actually row gets changing dynamically then we should select the particular cell. After matching to row condition then select cell from table

@lakshmipriya_a try using the If-Else condition in For Each loop in this case:

For each row: if the ${row} contains the current date, then assign the value of cell3 in the row to the variable ${cell}, for example.

am able to see only element

You can rename “element” any way you want (row, column, etc), and you can choose whether to iterate by rows or columns.
You can read more “For each” loop action in the Knowledge Base:

for sample :when I tried to copy value from cell its copying whole data from table ?

actually I want only selected cell row be changing dynamically but column is 5 .kindly help on this.

@lakshmipriya_a what exactly do you need the bot to do if the row contains previous date?

row 3 contains Previous date (data) corresponding to that row I need to select column 6 contains hyperlink pdf (data)

dummy_row 1
dummy_row 2
dummy_row 3
col1 col2 col3 col4 col5 col6
Edit abcd 10/1/2018 dummydata Signed 1.pdf
Edit xyz 10/17/2018 dummydata Signed 2.pdf

this is sample table am working on. based on the date checking , I want to download the pdf file.

Do you need to click on the link in cell 6?

Try using Click on Text option:

If the row (element) contains previous date, click on the text in element[6]

This solution is working when we assign the data to table first .In my case we taking data from clipboard and then assigning to table ,so here it selecting wrong column data .(as per above table format its select col6 and edit data)


please give clarify on this concept.

@lakshmipriya_a could you share your recording to have a look?

Please share the folder with the recording file (.rpae).
The folder is stored in the workspace (default location is C:\Users\user\workfusion-workspace\rpae_project).

hi ashapkina ,i shared the recording file. please check and kindly give me a solution.

Hi @lakshmipriya_a sorry for delay. As far as I could see, the problem must be in the “date-array” table - in the execution log it is shown like it has 1 row, not 3.
Try using Linux/Mac OS as the row separator.

The value in column 6 is the work Edit. Does the bot have to click Edit?

@lakshmipriya_a I noticed that you work with Salesforce in a browser. Perhaps, you can copy values using web actions in this case, so there will be no need to use clipboard

Thank you so much Ashapkina .its worked with filter options .

1 Like


mouse click is throwing error because there are two text results .this in case what is the solution.kindly share your solution

@lakshmipriya_a in this case, maybe you can click on the Xpath. Use the xpath for the column in which the cell you need is situated, and access a particular cell using index. Add an action to increment an index in the For each loop.

This Xpath //*[@class=‘w3-table-all notranslate’]/tbody/tr[${index}]/td[2] , for example, will click the cell 2 in row defined in the ${index} on this page

@ashapkina In my case its throwing an error while mouse click action .

here am attaching sample code (9.9 KB)