Inspector doesn't see empty cells in Excel

Assignment 9: Object recording in ExcelPage

I have a few questions regarding the task.

I cannot choose an empty cell in an Excel file. I tried to do it using:

  • Window control - Capture from screen;
  • Writing the path in Selector as [CLASS:DataItem; NAME:C4] and [CLASS:DataItem; NAME:“C” 4];
  • Inspector.
    And every time I got the same error: element doesn’t exist on the window. Could you explain to me the reason and how to fix this?

Also, I tried to launch Excel using Launch Application by writing the path to the app and file from variables one by one as it was shown in one of the videos (${path_app} ${path_file}). The bot works correctly in case the file is on the desktop. But if the file is in a folder and its path has more symbols, Bot divides the path into 2 parts and the execution fails. How can I avoid this?

Many thanks and have a great day! :slight_smile:

Hi @YuliiaPavlova what version of Excel do you have?

Hello Alesia,

MS Excel 2016

1 Like

When you inspect the sheet using Capture in the Inspector, can it select an individual cell like this?
Or does it highlight the whole sheet?

image

Also, try using other selectors, like .DataItem[name=’“C” 4’] or //*[@class=‘DataItem’][@name=’“C” 4’].

I have this kind of situation
And changing selector type in Inspector, unfortunately, doesn’t work

1 Like

Thanks a lot for the video @YuliiaPavlova
It looks like it might be a bug. We will investigate. I’ll keep you posted about it.

As a workaround for this assignment, try putting some default value in the cell.

@YuliiaPavlova could you please also share details about your Excel version?

You can find it in File - Account - About Excel

Thank you!
Here is the necessary info
image

Would you be so kind to answer the second question too? Thank you once again!

1 Like

Thanks!
Sure, didn’t notice it at first.

Does the path to the Excel file have spaces? If it does - it is a known issue with excel. It won’t work if you do the same manually through the Run dialogue when specifying the application
image

Not sure we can fix it from our side.

You can open such file by pressing Win+R and typing the path the file.

1 Like

@YuliiaPavlova I’ve moved your question to the Bug Reports category.