Inspector selects entire screen,not able to fetch specific path

Hi @ashapkina have tried to inspect element from chrome but Instead of selecting path of that element it selects entire screen.
why does this happen ?
Is there some way to overcome this?
Please let me know

Thanks in advance

Are you trying to inspect an element inside a web page?

Yes ,I have tried to inspect element in Chrome web page

Inspector is used for desktop automation only, it cannot inspect elements inside web pages.
You can see how to automate wen pages here:

I tried using xpath aswell but not able to fetch any data from chrome.
I have checked my xpath using " ctrl F" It was correct,but still niot able to click on any button or extract data .
Is there any possibility of version change,Do i need to install any specific version or should i change any configurations.

Do you get any error message when you run the script?

If i try to click on any button it throws an error saying that “Error executing Mouse click action”
caused by:
Error executing MouseClickAction
Caused by: org.openqa.selenium.NoSuchElementException: no such element: Unable to locate element: {“method”:“xpath”,“selector”:"//*[@id=“ng-app”]/body/nav/div/div[2]/ul[1]/li[2]/a"}
(Session info: chrome=77.0.3865.120)
(Driver info: chromedriver=2.44.609538

It cannot find the element with such XPath on the page.

Perhaps, the XPath is wrong, or the element is located inside an iframe.

It is not in an iFrame aswell

When i click on a button, It moves to seperate new window in a full screen mode(not in a tab)
In this screen, I am not able to click on any button and not able to fetch any data

I have used Switch to browser action
I have tried given this xpath as well:
Still it doesn’t work :sob:
I have to find a solution as soon as possible :cry:

If the page opens in a new screen, you need to switch to it using a custom action.

See this topic for more details

1 Like

Thanks a lot

1 Like