Installation Issues - How to Install RPA Express

installation
issues

#1

Hi, I have downloaded the setup of workfusion and trying to install it. I am getting following error.
Any thoughts why this is happening?


RPA Express 1.1.6 is rolled out
OCR action , failed to execute OCR action
#2

@Gaurav_Chauhan_IBM2,

please send here the log file (can be opened by the link)


#3

Hi, I have exactly the same problem with the installation failing.
I’d upload my log file but I don’t seem to be allowed. :frowning:

So here’s an extract from the end of the log …
[14DC:1D90][2017-04-11T10:08:56]i305: Verified acquired payload: cab63FCEF5DE81BB6842CD8C9AF4A8D0C4C at path: C:\ProgramData\Package Cache.unverified\cab63FCEF5DE81BB6842CD8C9AF4A8D0C4C, moving to: C:\ProgramData\Package Cache{940B81FE-080D-4F90-9869-DFDF868F13FD}v1.0.1\resources\cab29.cab.
[26C4:0594][2017-04-11T10:08:56]i338: Acquiring package: WorkFusion_RPA_Express.msi, payload: cabDC3C8448B1B02942391040AB41CE7277, copy from: C:\RPAExpressInstaller\resources\cab30.cab
[14DC:1D90][2017-04-11T10:08:57]i305: Verified acquired payload: cabDC3C8448B1B02942391040AB41CE7277 at path: C:\ProgramData\Package Cache.unverified\cabDC3C8448B1B02942391040AB41CE7277, moving to: C:\ProgramData\Package Cache{940B81FE-080D-4F90-9869-DFDF868F13FD}v1.0.1\resources\cab30.cab.
[14DC:230C][2017-04-11T10:08:57]i323: Registering package dependency provider: {940B81FE-080D-4F90-9869-DFDF868F13FD}, version: 1.0.1, package: WorkFusion_RPA_Express.msi
[14DC:230C][2017-04-11T10:08:57]i301: Applying execute package: WorkFusion_RPA_Express.msi, action: Install, path: C:\ProgramData\Package Cache{940B81FE-080D-4F90-9869-DFDF868F13FD}v1.0.1\resources\WorkFusion RPA Express.msi, arguments: ’ ARPSYSTEMCOMPONENT=“1” MSIFASTINSTALL=“7” WIXBUNDLEORIGINALSOURCE=“C:\RPAExpressInstaller\RPAExpressInstaller.exe”’
[14DC:230C][2017-04-11T10:29:44]e000: Error 0x80070643: Failed to install MSI package.
[14DC:230C][2017-04-11T10:29:44]e000: Error 0x80070643: Failed to execute MSI package.
[26C4:21B0][2017-04-11T10:29:44]e000: Error 0x80070643: Failed to configure per-machine MSI package.
[26C4:21B0][2017-04-11T10:29:44]i319: Applied execute package: WorkFusion_RPA_Express.msi, result: 0x80070643, restart: None
[26C4:21B0][2017-04-11T10:29:44]e000: Error 0x80070643: Failed to execute MSI package.
[14DC:230C][2017-04-11T10:29:44]i301: Applying rollback package: WorkFusion_RPA_Express.msi, action: Uninstall, path: (null), arguments: ’ ARPSYSTEMCOMPONENT=“1” MSIFASTINSTALL=“7” WIXBUNDLEORIGINALSOURCE=“C:\RPAExpressInstaller\RPAExpressInstaller.exe”’
[26C4:21B0][2017-04-11T10:36:33]i319: Applied rollback package: WorkFusion_RPA_Express.msi, result: 0x0, restart: None
[14DC:230C][2017-04-11T10:36:33]i329: Removed package dependency provider: {940B81FE-080D-4F90-9869-DFDF868F13FD}, package: WorkFusion_RPA_Express.msi
[14DC:230C][2017-04-11T10:36:33]i351: Removing cached package: WorkFusion_RPA_Express.msi, from path: C:\ProgramData\Package Cache{940B81FE-080D-4F90-9869-DFDF868F13FD}v1.0.1
[14DC:230C][2017-04-11T10:36:33]i372: Session end, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall{61cb90b0-985e-4d6c-8c8f-2a37ee6f562a}, resume: None, restart: None, disable resume: No
[14DC:230C][2017-04-11T10:36:33]i330: Removed bundle dependency provider: {61cb90b0-985e-4d6c-8c8f-2a37ee6f562a}
[14DC:230C][2017-04-11T10:36:33]i352: Removing cached bundle: {61cb90b0-985e-4d6c-8c8f-2a37ee6f562a}, from path: C:\ProgramData\Package Cache{61cb90b0-985e-4d6c-8c8f-2a37ee6f562a}
[14DC:230C][2017-04-11T10:36:33]i371: Updating session, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall{61cb90b0-985e-4d6c-8c8f-2a37ee6f562a}, resume: None, restart initiated: No, disable resume: No
[26C4:21B0][2017-04-11T10:36:33]i399: Apply complete, result: 0x80070643, restart: None, ba requested restart: No

Added the log file …
WorkFusion_RPA_Express_20170411100815.log (20.7 KB)

Cheers
Alan


#4

@Alan_Jacobs_IBM2

There should be more detailed log file - should look like ‘C:\Users{username}\AppData\Local\Temp\WorkFusion_RPA_Express_20170331221403_000_WorkFusion_RPA_Express.msi.log’

Please send it here as well.

Best regards,
Yauhen Khatsuk


#5

Found it but can’t upload it as even in zipped form it is 7.9mb. ( 183mb uncompressed )
Do you have any other upload facilities?
Cheers
Alan


#6

Could you please search entire log for the ‘Exception thrown’ key words and provide the stack trace?

Should look like:

Exception thrown by custom action:
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. —> System.IO.DirectoryNotFoundException: Could not find a part of the path ‘D:\ABSOLUTEPATH’.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.Directory.Delete(String fullPath, String userPath, Boolean recursive, Boolean checkHost)
at RPASetup.CustomAction.PostUninstallSteps(Session session)
— End of inner exception stack trace —
at System.RuntimeMethodHandle.InvokeMethod(Object target, Object arguments, Signature sig, Boolean constructor)
at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object parameters, Object arguments)
at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object parameters, CultureInfo culture)
at Microsoft.Deployment.WindowsInstaller.CustomActionProxy.InvokeCustomAction(Int32 sessionHandle, String entryPoint, IntPtr remotingDelegatePtr)
CustomAction Action3_PostUninstallSteps returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

Best regards
Yauhen


#7

Got it … not allowed to update the hosts file.
Configuring Company ID
Original source: C:\RPAExpressInstaller\RPAExpressInstaller.exe
Source dir: C:\RPAExpressInstaller
Configured Company ID
JRStart Hub & Node
JVM patched
Exception thrown by custom action:
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. —> System.UnauthorizedAccessException: Access to the path ‘C:\Windows\system32\drivers\etc\hosts’ is denied.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy)
at System.IO.FileStream…ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy)
at System.IO.FileStream…ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options)
at System.IO.StreamWriter…ctor(String path, Boolean append, Encoding encoding, Int32 bufferSize)
at System.IO.StreamWriter…ctor(String path, Boolean append, Encoding encoding)
at System.IO.File.AppendAllText(String path, String contents, Encoding encoding)
at RPASetup.CustomAction.ConfigureHosts()
at RPASetup.CustomAction.PostInstallSteps(Session session)
— End of inner exception stack trace —
at System.RuntimeMethodHandle._InvokeMethodFast(Object target, Object arguments, SignatureStruct& sig, MethodAttributes methodAttributes, RuntimeTypeHandle typeOwner)
at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object parameters, CultureInfo culture, Boolean skipVisibilityChecks)
at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object parameters, CultureInfo culture)
at Microsoft.Deployment.WindowsInstaller.CustomActionProxy.InvokeCustomAction(Int32 sessionHandle, String entryPoint, IntPtr remotingDelegatePtr)
CustomAction Action1_PostInstallSteps returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended 10:17:28: Action1_PostInstallSteps. Return value 3.
Action ended 10:17:28: INSTALL. Return value 3.

Cheers
Alan


#8

It can happen if you have antivirus software installed. If it’s the case please try to disable it temporarily and try installation again.

Best regards
Yauhen


#9

Hi, Sadly I am not able to disable the antivirus as its locked. Even killing the process fails as it just restarts immediately. This is a company supplied image running in VMware ( on a Macbook )

So I tried to install on my home PC. Tried using Windows 10 and Windows 7 but both failed with the same error …0x80070661 This installation package is not supported by this processor type.

Both of these instances are virtual and run under Oracles Virtualbox ( on a Linux pc )

So not much joy today I’m afraid.

Cheers
Alan


#10

Windows Defender detected a known, high-risk Trojan in the installation, which is why your installation might be failing…and it should. I have sent this to the RPA Express team as well to let them know that there is potentially harmful code in their package.

Just to confirm…I downloaded this directly from the RPA Express link that was sent to me for the trial.


#11

Same story i tried disabling the anti-virus however not able to install. Looks like Jon may have a point above.


#12

I had similar issues during installation. However, here are the few steps that I took which seems to have resolved the issue:

  1. Go to windows
  2. Search for cmd
  3. right click and select run as administrator.
  4. go to the folder where the files are unzipped.
  5. run RPAExpressInstaller.exe from the command prompt.

Hope this helps.


#13

Tried going through Command Prompt - I went to Safe Mode with Networking as well. Install keeps giving same error.


#14

Please try repairing the .net framework using the below url and then try installing. I was getting the same error but it was resolved after repairing the .net framework.


#15

Hi Alain,

It looks like you tried to install RPA Express on 32 bits OS. Please note that only 64bits OS are currently supported.

Best regards
Yauhen


#16

Hi, having the same problem…

Error 0x80070643: Failed to install MSI package.

Please find attached the log file.

WorkFusion_RPA_Express_20170418101727.log (20.2 KB)

Appreciate your help.

Thanks & best regards,
Lennart


#17

Hi, I am facing same problem…

Error 0x80070643: Failed to install MSI package.

Would appreciate your help in resolving it.

Regards,
Avinash Damle


#18

Issue resolved.
I just changed Windows Firewall setting in ‘Services’ and it worked.


#19

I have fatal error with following code 0x80070570
Any help with this?


#20

@janis.pundurs
Please send the installation logs as described in Troubleshooting