Is there a way to schedule the start of workfusion & control tower & all its components?

I need to schedule bot’s execution. Over a period of testing, I have realized that some components of workfusion like control tower and bot manager become inactive & the bot actually doesn’t execute.

So I have two questions:

  1. Why some components become inactive at time & stop the scheduled bot from executing? Has anyone faced the same issue or is it a system specific issue?
  2. Is there a way to start control tower automatically when the system is on scheduled re-start?

@ashapkina - Please share your thoughts, if possible.

1 Like

Hi @spectator,

you can change the settings of RPA Express components in the file C:\RPAExpress\RPA\wfagent\expres.yml to make them start by default when RPA Express is launched.

For components: ocr, tomcat, mysql, postgres, - change the startup parameter to true.

Then add RPAExpress application to Windows startup, and all components will start automatically after the system restart.

As for the first question, I understand that our support team are working with you on it, so I will leave it to them in order not to duplicate it.

Hope it will be helpful.

3 Likes

Hi @ashapkina,

In version 2.1.1 file express.yml does not exist in directory RPAExpress\RPA\wfagent\

@adimitriou yes, these settings are now stores in several files in folder C:\RPAExpress\RPA\wfagent\settings

@ashapkina Thanks!

@ashapkina I found the relevant records in files and changed startup to true, but Control Tower does not start automatically when I start RPA from Desktop icon, like in version 2.0.
We have to change anything else in version 2.1?

@adimitriou make sure you changed all three parameters for Control Tower:

  • tomcat (in app.yml file)
  • mysql
  • postgres (both in db.yml file)
1 Like

Yes, that’s what I changed.
But it doesn’t work.

@adimitriou caould you share screenshots of these settings?

app.yml
image
db.yml

@adimitriou thank you.
Please make sure you have saved the modified files, restart the computer and start RPA Express again. If Control Tower still doesn’t start by default, let me know.

Saved files again (to be sure).
Power Off.
Start and it works!

@ashapkina Thank you for your help.

1 Like

Glad it helped!

Hi Ashapkina
Can you specify which files I need to alter - I installed version 2.1.5 in the beginning of december 2018
Best regards,
Michael Callisen

You need to change these files:

C:\RPAExpress\RPA\wfagent\settings\app.yml
C:\RPAExpress\RPA\wfagent\settings\db.yml

Hi Ashapkina,

I just updated to version 2.2 - is it still these files?

Best regards,
Michael

Yes, the same files

Starting from version 2.3.0, you can set Control Tower and other RPA Express components to start automatically in the background every time you start the system.

To do it, you need to enable the mode “Always running” in the Components tab in WorkFusion Studio.

image

2 Likes

3 posts were merged into an existing topic: WorkSpace unavailable, Control Tower has no button to start it