Launch Application not starting .bat file

Hellow,

We are trying to start the test.bat file with the recorder, in the steps it presents no errors but does not start.

then the code in the test.bat file:

@echo off
color A
echo ######################################
echo Hello WorkPress !!!
echo .
echo ######################################
pause

Action flow executed successfully, but did not execute file:

Manually executed file:

image

Privilege for user to run:

Note: User logged in on the desktop is an administrator.

Thanks,
Mauricio

@mauricio_araTp
Launch application action cannot execute files that open cmd.
You can execute it through Win+R.

In the new version of Workfusion Express 2.0 the key combination (Win + r) does not work.
And Launch Application does not work to run a bat file either.
What do you have to do then to execute a bat file?

Thank you

@jamo Win+r has to work in the new version.
Does it show any error when you try to run it?

No, it does not show any error. It just does not do anything.

Hmm, weird. I just tested it on a small script, and it worked :thinking:
Could you try running the Hello World sample on the Welcome page (you can find it in Help). Does it not works there as well?

Can you send me the help link? Thank you.

Sorry, my explanation was confusing.
You can open it directly in the Studio.

image

Now when you run win + r the search panel of windows 10 opens, not the one to execute.

I execute this:
image

And this appears:

Greetings.

Hi ashapkina.

I think the problem is that the speed of sending the keys with the Enter Keystrokes command is slower than with version 1.4 and that’s why Win + R. does not run well.
Why is the Enter Keystrokes command slower now?

Greetings.

I ran it several times, and one time the search panel did open instead of the Run panel. It still executed the script correctly, thought. I don’t know if it is related to the speed of execution, we’ll investigate why this happens.

@jamo we are planning to fix this issue within a couple of weeks

Agree.
I await your news.
Thank you.

1 Like

@jamo the issue with Win + R has been fixed in the new build.

Thank you.
I’ll download it. Do I have to uninstall version 2.0 first?
Greetings.

Hi Juan,
No need to. You can use the Update option.

Agree.
Thank you very much.