Launch failure of RPA Express 1.2.0 and 2.0.1- Failed to send old playback events

Hi All,

I am trying to install and run RPA express on Windows 7 professional N-7601. Installation completes successfully, but when I try to run it, only a screen comes up and goes off without any error message.

I checked the logs(attached) and found the error to be

"[taskScheduler-2] ERROR c.w.s.c.f.ActionEventsLogFunction - Failed to send old playback events
java.nio.file.NoSuchFileException: C:\Users\user\workfusion-workspace.metadata"

When i check the address given I found no folder named “workfusion-workspace” in the user folder. Seems like while installation is done this workspace folder should automatically be created, but somehow it is not.

I have checked and commented on forum question - https://forum-2-new.workfusion.com/t/unable-to-launch-workfusion-rpa-express/39295/6 but their logs mention a separate error hence i am creating a request of my own.

Any help would be appreciated. We have seen the issue on installation of both versions 1.2.0 and 2.0.1.

Attahcments- logs visible on installation of RPAExpress-1.2.0
status-agent-error.log (31.0 KB)
status-agent.log (76.5 KB)

Thanks and Regards,
Keval Kapadia

Hi @keval_kapadia, are you referring to version 1.2.0 or 2.0.1 in the text?
1.2.0 is an old version which we do not support anymore.

If you have installation logs and these logs for versions 2.0.0 or 2.0.1:
C:\RPAExpress\RPA\wfagent\logs
C:\RPAExpress\Workfusion\tomcat\logs

please send them over - we’ll have a look.

Thank you.

Thanks for a really quick response Alesia,

The error is of same nature in this version too. As asked, please find below the logs for version 2.0.1:

status-agent-error.log (46.8 KB)
status-agent.log (127.3 KB)

1 Like

@keval_kapadia please check if you have file .identification in the installation package.

image

@ashapkina Yes, I see a .identification file.

Please see below:
identification%20file

Thank you @keval_kapadia.

Are these two files the only logs you have in C:\RPAExpress\RPA\wfagent\logs? If there are any other logs there, please send them, too.
Please also send installation logs from C:\Users%username%\AppData\Local\Temp folder, and check if you have permission to create files in C:\Users%username%\ (just try creating a test folder with a couple of files inside).

Hi @ashapkina,

The error message is not the one that i have mentioned. I was only looking at the top of the file- my mistake.

The real error message seems to be:

"२०१८-०६-२५ १६:२१:५२ [main] ERROR o.s.boot.SpringApplication - Application startup failed
org.springframework.beans.factory.BeanCreationException: Error creating bean with name ‘waitIconUtil’: Invocation of init method failed; nested exception is java.lang.IllegalArgumentException: input == null!"

Hope this helps.

Thanks,
Keval

@keval_kapadia yes, we saw it in the logs, but it is not yet clear why this error occurs.

You wrote that you had this error in 1.2.0 before.
Did you manage to successfully install and launch any other RPA Express version, or did you always have this issue?

I was not able to install any of the RPA versions.

@keval_kapadia ok, thank you.
Could you please check if you have permissions to create files and folders in C:\Users%username%\

@ashapkina Yes, I am the admin of the system. I just checked also if i am able to create a folder. I was.

1 Like

I have tried running the Studio separately using
"C:\RPAExpress\Studio\workfusion-studio.exe"

But I am unable to run the Workflow recorded. I get this error
"Unable to connect with robot"

I am guessing this is because my Bot Manager is not running. As I can’t see anything in my tray of icons, which it should ideally show.

@ashapkina

There were multiple files in the log but only these two were the non empty ones.

filenames

I can’t see any folder named AppData as you mentioned in the address
"C:\Users%username%\AppData\Local\Temp folder"

You need to change the settings to see hidden files:

  • Start - Control Panel - Appearance and Personalization
  • Folder - View. Under Advanced settings, select Show hidden files, folders, and drives, press OK.

This seems to be a specific issue, so I forwarded it to our support team. They’ll contact you shortly via email.

1 Like

Thank you so much.

I have installed this software multiple times now. Please find attached the log files of the latest installation.

WorkFusion_RPA_Express_20180621165336.log (7.1 KB)
WorkFusion_RPA_Express_20180621165716.log (27.3 KB)
WorkFusion_RPA_Express_20180621165716_003_WorkFusionOCR.log (3.3 MB)
WorkFusion_RPA_Express_20180621165716_002_WorkFusionRecorder.log (4.7 MB)
WorkFusion_RPA_Express_20180621165716_005_WorkFusionRPA.log (6.4 MB)
WorkFusion_RPA_Express_20180621165716_000_WorkFusionRPAExpress.log (7.2 MB)

Two of the files failed as the file sizes were 31MB and 17MB respectively

Thanks,
Keval

Hi Keval,

I believe this issue was solved by installing RPA Express on Windows 10? Let me know if you have any issues.

1 Like