Mouse click by image doesn't work

First, i can’t open app by launch application so i am using keystrokes win+r and it works. Second, the window app has opened but i can’t click menu by image or use keystrokes in that app, all doesn’t work. Please help me, give me a solution. Thank you.

HI @umay can you share your recording or the screenshots on the actions that fail?

hallo @ashapkina yes i can.

There was no error but the action didn’t work. This is the application display.

Regarding the issue with the Launch Application: are you trying to run an .exe file or another type of file?

Regarding the issue with the mouse click: did the bot not click on the image but it was marked with a green mark in the Actions flow?

Regarding the issue with the Launch Application: Yes i am trying to run an .exe but i get an issue so i change by keystrokes win+r.

Regarding the issue with the mouse click: Yes it’s true, the bot not click on the image but it was marked with a green mark in the Actions flow.

Thank you.
Can you share the screenshot of the mouse click action with action details?

do you mean like this?

Hi @umay,

Could you please share the Target properties of the click image as sample shown below,

Please let us know which menu you are trying to click from the image you shared.

Thanks in Advance :slight_smile:

1 Like

like this?

and others use keystrokes.

The menu that I marked is red, I want to choose one of these databases but use keystrokes down because using the mouse click doesn’t work. and using keystrokes also doesn’t work. Then the ‘Pilih DB’ button uses a mouse click but it doesn’t work.

1 Like

@umay it looks like the bot doesn’t see this application and cannot interact with it.
Could you please try and inspect this application using Inspector? Does it see it?

Also, is this an internal custom application or can we download it somewhere to test?

1 Like

can’t because it’s not web, I’ve tried it. using the inspector mouse is also null. this is a government-owned application. here is the tutorial link https://youtu.be/f69sEMBZ38U

Hi @umay,

Did you try using the click image using co-ordinates? so that it doesn’t rely on the image instead it will go to the screen co-ordinate position and perform the click actions.

Could you please try that and let me know if that works?

Please go with “Insert Recording” and record each actions of click button and thus you will get any one of the three properties.

Note: The thing is you have to stick with same screen monitor resolution.

Thanks for the response :slight_smile:

I have tried using image clicks using coordinates and the results are the same as clicking the mouse with the image there is no problem but it doesn’t work. and also entering a recording, I didn’t get an action from the mouse click. recorded only when double-clicking the application. You can try this application and this is the installer https://drive.google.com/file/d/1h0BQeWlferKLvYdaS1iqEN6dHfd0RoMD/view?usp=sharing and this is a tutorial to install https://youtu.be/f69sEMBZ38U, thank you for the response :slightly_smiling_face:

hello @ashapkina and @aravindhan_mr,

how for this case, do you have a solution for this? , for testing the application you can download it at https://drive.google.com/file/d/1h0BQeWlferKLvYdaS1iqEN6dHfd0RoMD/view?usp=sharing

Thankyou.

Hallo @ashapkina @aravindhan_mr I’m sorry, I want to ask again about the issue of what i asked above. Do you get the solution? Tell us please. Because we want to work on a project that should be done in this month. Thank you :pray:

Hi @abdu_rachman and @umay

We have done some testing, and it turns out that this application requires administrator access.
To automate it, you need to run RPA Express as administrator.

image

Please let me know if it doesn’t help.

2 Likes

Thank you so much @ashapkina it’s very helpful and it’s work. :slightly_smiling_face::pray:

1 Like

Thanks for the update @umay glad it works :slightly_smiling_face:

2 Likes